My laptop will connect to the wifi but there is 'limited access'

Not open for further replies.


Jan 25, 2016
I have an ASUS laptop and it's usually ok about connecting to my home wifi. It's been almost a week that I've been using my phone for just wifi. I can get onto the network, but it's always showing 'limited access' when it's connected. I've tried resetting the router and restarting my computer. I've even 'forgot the network' shut off wifi capabilities and tried reconnecting. I don't have access to the router setting though.

First, is it just your ASUS laptop that is not connecting to your wireless network? Please do try these troubleshooting steps that may help in solving the issue.
- Start by uninstalling/reinstalling the wireless adapter.
- Go to Device Manager and uninstall the wireless adapter.
- Reboot your laptop and it should reinstall the driver automatically upon reboot.
- If it will not reinstall, download and install the latest wifi driver from Asus support site.
- Once installed do try connecting to your wireless network again.
- Also please do try these troubleshooting steps.
- If all these will not work do try to uninstall the antivirus installed in your laptop then try it again.
- Your last resort would be to reinstall Windows itself if all these will not work.

If its not just your Asus laptop that won't connect to the network I would suggest contacting your ISP first.
Not open for further replies.