My toshiba c600 laptop dosent turn on. When pulg my charger at that time charging bulb also dosent work but charger is workin

May 12, 2018
1
0
10
0
Help
My toshiba c600 laptop dosent turn on. When pulg my charger at that time charging bulb also dosent work but charger is working properly (19v)
 
NOTE: Yes, I know some batteries are not so easy to get to, on some devices. However, it should be removable/replaceable. Unless it is under warranty, then you should contact the manufacturer first.


Try the following and see if it will turn on...

1. Unplug your charger cord.
2. Remove the battery.
3. Press and hold the "Power" button for 30 seconds.
4. Now plug back in the power/charger cord.
5. Now put the battery back in.

If this doesn't help, then test the power cord to see if it is good. Either try your cord in another device, or try another devices cord in your laptop. You may also want to try charging it when the device is off, rather than on. If it works then, the cord is probably the issue.

Should that not be the problem, then check the battery to see if it needs replacing.

 
Thread starter Similar threads Forum Replies Date
M Laptop Tech Support 1
S Laptop Tech Support 0
S Laptop Tech Support 3
M Laptop Tech Support 1
S Laptop Tech Support 3
N Laptop Tech Support 2
mfenton27 Laptop Tech Support 4
Alwise901 Laptop Tech Support 3
S Laptop Tech Support 2
J Laptop Tech Support 1
F Laptop Tech Support 1
L Laptop Tech Support 1
G Laptop Tech Support 1
D Laptop Tech Support 2
N Laptop Tech Support 0
M Laptop Tech Support 2
T Laptop Tech Support 0
D Laptop Tech Support 1
C Laptop Tech Support 0
M Laptop Tech Support 1

Similar threads


ASK THE COMMUNITY

TRENDING THREADS