Nakamichi ST-7 - Presets not kept in memory

Status
Not open for further replies.

Jimmmbo

Distinguished
Aug 24, 2006
2
0
18,510
0
Hi,

I've got a Nakamichi ST-7 tuner. It used to keep chennel preset in memory for a long time but now I have to give it power about every four or five days if I want the presets to stay in memory. I saw an article in a review forum indicating that there was a battery that could be replaced, but when I opened up my ST-7, I couldn't find a battery.

Could any tell me how I could fix the problem with presets not staying in memory or, if there is a battery, where it is, what it looks like and how to replace it?


J
 

eleakist

Distinguished
Sep 6, 2006
2
0
18,510
0
I do not see a posted reply but hope you have found the answer. I purchased an ST-7 and am very pleased with it. I received the tuner on Aug 31 and left it on until reading your post. Turned it off for 8 hours and, shazzam, no memory. Do you have any further info or determined the cause. My first guess would have been a cap, not battery, so have ordered a schematic so I can sort this out.
 

Jimmmbo

Distinguished
Aug 24, 2006
2
0
18,510
0
Hi,

No reply so far. I would bet that you're right. The battery comment was based on another post. But I opened up the tuner and took a very dtailed look but could not find a battery. Some capacitors close to the presets area though.
 

eleakist

Distinguished
Sep 6, 2006
2
0
18,510
0
As it seems we are both trying to solve the same issue, I will report my findings via a post to this site. Please do the same should you resolve.

Thanks

Barry
 
Status
Not open for further replies.

ASK THE COMMUNITY