Need help with bass on my speakers

May 2, 2018
2
0
10
0
I have Sony 2 channel 270 have home receiver and will not push my woffers hardly no bass checked my wires and everything is fine there but my receiver has no sub woofer hook up just speaker 1 and speaker 2
 
If you are not getting any bass at all from your speakers then the woofers in them may be blown.
If the speakers have bi-wire terminals there should be a connection between the two plus and the two minus terminals. If you don't have that in place and the wires from the receiver are connected to the top terminals you won't get any bass.
If the problem is that you aren't getting enough bass then you can get a subwoofer with speaker level inputs or use a speaker to line level converter with any subwoofer with left and right line level inputs.
 
If you are not getting any bass at all from your speakers then the woofers in them may be blown.
If the speakers have bi-wire terminals there should be a connection between the two plus and the two minus terminals. If you don't have that in place and the wires from the receiver are connected to the top terminals you won't get any bass.
If the problem is that you aren't getting enough bass then you can get a subwoofer with speaker level inputs or use a speaker to line level converter with any subwoofer with left and right line level inputs.
 
Thread starter Similar threads Forum Replies Date
T Audio 1
S Audio 5
D Audio 2
P Audio 4
S860 Audio 2
Luckky99 Audio 6
C Audio 0
choeandrew1208 Audio 0
H Audio 0
C Audio 1
Smackiepipe Audio 6
M Audio 1
I Audio 0
TPrime8 Audio 0
beso140 Audio 0
J Audio 0
HorseMan1017 Audio 0
S Audio 1
T Audio 2
C Audio 1

ASK THE COMMUNITY