Question New Acer Nitro 5, browsers keep losing connection until restart

Jul 20, 2022
1
0
10
0
Hello all,

I have a really weird problem and cannot seem to find anything online that might shed some light on it, so I'm hoping someone here can help out. I recently purchased an Acer Nitro 5 laptop (an517-42) and am pretty happy with it, except for the fact that several times per day all of my internet browsers will simply stop working until I restart. All other internet connectivity is fine; I can still use Steam, Origin, Telegram, etc. Additionally none of the other devices in my house encounter this problem, including my work laptop, my son's laptop, TVs, phones etc. The internet works flawlessly on all of them; the only thing that stops connecting is my browser(s), and it doesn't matter whether I'm using Firefox, Chrome, Edge or even Steam's in-game browser.

Once I restart the laptop, everything works fine for awhile, and then it reoccurs. I tried updating the wireless drivers but they're already updated to the most recent version. I tried resetting the network, reinstalling the browsers, and even though I only use this for gaming and don't go to any risky websites, and even though I've only had it for a few days, I've installed Malwarebytes and run several scans, thinking maybe it was some kind of virus. Nothing. I've also tried switching back to the 2.4Ghz band instead of 5G on my network; didn't work either.

Since it's running Windows 11 I thought maybe it's an issue with the OS, so I called MS support. They were clueless. So I figured maybe I just got a laptop with a defective network card or something; it happens, no big deal I'll just go exchange it. So I returned it for a new one, same make and model. And I'm running into the same problems all over again.

So now I'm at my wit's end because it really sucks to have to stop what I'm doing and restart my laptop 4 times a day. The only thing I can think of that might be an issue that I haven't checked is a BIOS update or maybe a compatibility problem with my old, crappy CenturyLink modem (Zyxel C3000Z).

If anyone could offer any insight as to what might be causing this and/or how to fix it, I would be so grateful. System info is listed below.

Acer Nitro 5 an517-42
Ryzen 7 6800h
RTX 3060 Laptop
16GB DDR5
RZ616 Wi-Fi 6e 160Mhz
Windows 11 Home Edition v 10.0.22000
BIOS Insyde Corp. V1.03, 5/25/2022
 
Thread starter Similar threads Forum Replies Date
GadgetTechMan Laptop Tech Support 0
J Laptop Tech Support 5
Jukeman_IronWulf Laptop Tech Support 1
T Laptop Tech Support 0
S Laptop Tech Support 4
A Laptop Tech Support 2
Oshadowassassin Laptop Tech Support 0
TaranWolf Laptop Tech Support 1
C Laptop Tech Support 1
S Laptop Tech Support 5
thekbw Laptop Tech Support 2
Ely10484 Laptop Tech Support 0
Shrey30 Laptop Tech Support 0
Scloopz Laptop Tech Support 5
Kaiserken Laptop Tech Support 1
E Laptop Tech Support 1
xdoji Laptop Tech Support 0
I Laptop Tech Support 4
D Laptop Tech Support 1
S Laptop Tech Support 0

ASK THE COMMUNITY