Nexus 7 Tablet (2013) won't come on or charge


Jul 16, 2016
Hi all, May I have some assistance please? My Nexus 7 Tablet (2013) has been dead for a month now and today I tried to charge it but it won't boot up. I left it for maybe 4 hours or more but it showed no improvement. I tried pressing down the power button and did that for about 60 seconds but nothing happened. The battery icon does not come up nor does the google icon. I also tried pressing the volume down and up together with the power button but that was also a fail. Can you please help me because I need to use my tablet for school.

Try holding down the power button for about 30 seconds and then plugging it in to charge. If it shows it is charging then it was probably just stuck, or drained the battery too far.

If it doesn't charge, try the cord on a different device, or a different cord on your device. If the problem is the cord, then that should solve it. If it doesn't help either, there are two options. Either you need a new battery, which is a tad hard to replace on your own, but can be done. However I would not suggest doing that if the device is under warranty. If it is, you should contact the manufacturer. If it isn't, then you can try to replace the battery yourself, just be extremely careful, or take it to a tech or local repair place to have them try and change it out.

Should that not work, you may need a new tablet.
Thread starter Similar threads Forum Replies Date
M Android Tablets 1
T Android Tablets 1
G Android Tablets 1
D Android Tablets 1
H Android Tablets 1
M Android Tablets 1
tomsguideUS Android Tablets 0
B Android Tablets 1
H Android Tablets 3
M Android Tablets 1
O Android Tablets 8
J Android Tablets 8
Daniel Harvey Android Tablets 6
T Android Tablets 1
S Android Tablets 4
I Android Tablets 2
V Android Tablets 6
V Android Tablets 2
Mr Burns Android Tablets 2
A Android Tablets 4