Question No Audio Being Sent from HDMI Audio Extractor to receiver

Jul 5, 2020
1
0
10
0
Hello,
New here. Hoping this is the right place to post this. I'm currently using the following HDMI switch/extractor https://www.amazon.com/gp/product/B07B3R9PD9/ref=ppx_yo_dt_b_search_asin_title?ie=UTF8&psc=1 As a bonus, this little box supports 4k@60hz though it says it does not, I can confirm it does. I have this box plugged into an Xbox One, Nvidia shield tv pro, Nintendo Switch, and Windows 10 PC. On the output ports, I have a 1080p projector and a 1080p sharp tv. The digital audio port extracts the audio and I have it plugged in to my receiver. I get digital audio from all the devices. I recently I purchase a Samsung q60r tv. Yes, I finally stepped into the 4k world. The tv supports hdr@60hz. To my surprise the HDMI switch I listed above worked great and supported the 4k@60hz. The issue is, it does not support hdr.
this is where the issues start I purchased the following 2 devices. The first one was this one. https://www.amazon.com/gp/product/B0814L36PV/ref=ppx_yo_dt_b_asin_title_o00_s00?ie=UTF8&psc=1 . I plugged everything in the same I did with my current working HDMI switch. The results were that all devices worked and hdr worked as well but there was no audio from the digital optical port. After hours of troubleshooting, i figured maybe there is something wrong with this box. I then ordered another box. I ordered this one thinking it was a bad box. https://www.amazon.com/gp/product/B07ZTWGBHL/ref=ppx_yo_dt_b_asin_title_o04_s00?ie=UTF8&psc=1 . I have the same issue with this one as well. After hours of troubleshooting, i put everything back to my old box and everything is working again on the old box. can anyone tell me what I'm doing wrong, or what I'm missing here?
 

ASK THE COMMUNITY