No sound through TV when using HDMI cable

Status
Not open for further replies.

Joshb873

Estimable
Feb 15, 2015
1
0
4,510
0
Okay, don't start by telling me to set the HDMI device as my default device. I know how it works.

My problem is,.even when my HDMI device is enabled, and should be working, there is no sound. I have always used the same HDMI cable and it has always worked, and the same set up I have now works perfectly fine through other TV's with the sound.

I noticed that in the device manager, the output property is set to 24bit, but my TV only supports 16bit? Then, when I try and change to 16bit so the sound will work, alas! I get a warning saying that my TV does not support 16bit. The whole situation is completely ridiculous. What is the problem? All of my drivers are up to date and working. I can get sound with headphones and all other devices, just not the TV.

Thanks in advance if anyone can help.
 

darkbreeze

Honorable
Moderator
Has the sound worked via HDMI with this TV before? It's possible you have an older HDMI standard on the tv that doesn't support the newer standard of your GPU. If it has worked in the past and only recently stopped working it could be that a recent driver update is to blame and you might need to rollback to an older driver for use with the tv.

If your TV has more than one HDMI input, you might try unplugging the hdmi, restarting both the TV and computer, then reinserting the connection to the tv. Might even try that if it has only one. Sometimes a restart on both devices without the connection attached will trigger a reset. Aside from that, I'm not sure how to get past the bitrate conundrum.
 

darkbreeze

Honorable
Moderator
Has the sound worked via HDMI with this TV before? It's possible you have an older HDMI standard on the tv that doesn't support the newer standard of your GPU. If it has worked in the past and only recently stopped working it could be that a recent driver update is to blame and you might need to rollback to an older driver for use with the tv.

If your TV has more than one HDMI input, you might try unplugging the hdmi, restarting both the TV and computer, then reinserting the connection to the tv. Might even try that if it has only one. Sometimes a restart on both devices without the connection attached will trigger a reset. Aside from that, I'm not sure how to get past the bitrate conundrum.
 

1SmartFox

Estimable
Jul 13, 2015
1
0
4,510
0
On a Mac... go to your Apple settings (top left corner); select "system preferences"; select "sound"'; select "output"; select "HDMI"; works with Yosemite, should work with all. Just remember to reset it.
 
Status
Not open for further replies.
Thread starter Similar threads Forum Replies Date
B Laptop Tech Support 1
D Laptop Tech Support 1
L Laptop Tech Support 4
Jaivik_Patel Laptop Tech Support 13
D Laptop Tech Support 1
S Laptop Tech Support 1
D Laptop Tech Support 1
W Laptop Tech Support 1
N Laptop Tech Support 3
M Laptop Tech Support 2
D Laptop Tech Support 3
J Laptop Tech Support 5
C Laptop Tech Support 1
G Laptop Tech Support 3
J Laptop Tech Support 1
A Laptop Tech Support 9
T Laptop Tech Support 1
D Laptop Tech Support 3
M Laptop Tech Support 2
Z Laptop Tech Support 7

ASK THE COMMUNITY