None of my browsers can login to any https:// sites (e.g. Amazon); page never loads

John Templeton

Honorable
Jul 5, 2013
2
0
10,510
0
Use FF 41.0.1 mostly, but this applies to when I try to use Chrome and IE as well.

Started a month ago.

I attempt to go to a site (Amazon and Snapfish for example) and immediately I am forced to the https version. For Amazon that looks like.

https://www.amazon.com/gp/gw/ajax/s.html

I attempt to login but it never works. It will be stuck in an infinite load cycle and never move from the login page.

Any ideas?
 

XtremeAero426

Honorable
Jan 4, 2014
47
0
10,610
10


Try these:

1. Clear your browser cache entirely.

2. Uninstall and reinstall your browser.

3. Run a MalwareBytes scan and let it clean everything for you.

 

John Templeton

Honorable
Jul 5, 2013
2
0
10,510
0
UPDATE:

When I use a VPN into my office network and try to access Amazon or Shutterfly, however, everything's fine again.

I ran a tracert (w/o VPN) and found I was timing out after about 9 steps to get to Amazon.

Talked to Amazon. Amazon says talk to my provider.

Talked to my provider (Cox). They claim my dynamic IP is on the SORBS blacklist from 9+ years ago. I have a request into SORBS to be delisted, but I was under the impression they blocked email. This isn't an email issue; I can't login!

Thoughts? Theories?
 
Thread starter Similar threads Forum Replies Date
M Apps General Discussion 0
M Apps General Discussion 5
C Apps General Discussion 5
S Apps General Discussion 1
henrytcasey Apps General Discussion 8
G Apps General Discussion 2
L Apps General Discussion 1
C Apps General Discussion 3
D Apps General Discussion 2
Y Apps General Discussion 1
M Apps General Discussion 5
O Apps General Discussion 1
D Apps General Discussion 2
henrytcasey Apps General Discussion 4
henrytcasey Apps General Discussion 1
O Apps General Discussion 4
S Apps General Discussion 3
W Apps General Discussion 4
B Apps General Discussion 6
B Apps General Discussion 1

ASK THE COMMUNITY