Question NVMe drive/BIOS boot detection and listing

Aug 27, 2021
1
0
10
0
ASUS Prime H370-A MoBo and Win 10 OS. I switched out the original SATA Drive for the NVMe drives 1 - 500GB for the OS and 1 - 1TB for storage. Both are Sabrent and both work fine, but neither shows in the start up BIOS screen before Win10 loads. Drives are visible in Explorer though. But on the start up screen that identifies/detects and lists line by line hardware, storage, memory, etc. there is no mention of the NVMe's . The computer runs fine and the drives are identified correctly on the UEFI screen. How can I get them to show up in BIOS portion of start up as my storage device? Originally, the SATA drive did get detected and was listed. Additionally, I also upgraded the RAM and it gets generically listed, by type (DDR4)and amount (32GB), but not by the Manufacturer's name (Crucial/Ballistix). Just curious if there is a way to "fix" this. BIOS is: American Megatrends version: 0802
 
Thread starter Similar threads Forum Replies Date
M Laptop Tech Support 9
R Laptop Tech Support 0
lucasblack29 Laptop Tech Support 1
newbie_techie Laptop Tech Support 6
A Laptop Tech Support 11
F Laptop Tech Support 1
P Laptop Tech Support 1
C Laptop Tech Support 3
S Laptop Tech Support 1
Z Laptop Tech Support 2
K Laptop Tech Support 1
O Laptop Tech Support 6
T Laptop Tech Support 2
S Laptop Tech Support 1
X Laptop Tech Support 1
C Laptop Tech Support 1
I Laptop Tech Support 5
M Laptop Tech Support 1
M Laptop Tech Support 11
LaCalia Laptop Tech Support 2

ASK THE COMMUNITY