Olympus camera problems

fedupandangry

Distinguished
Nov 18, 2009
2
0
18,510
0
i have an olympus FE-5010 whenever i turn it on the lens comes out and goes back in at least 3 times before it stays open and then the screen is black. Its also telling me that the battery is empty and this can be so because I've charged it and also placed a new battery in it. The lens also would not go back in when i turn off the power. Please help
 
G

Guest

Guest
This is generic advice on stuck lenses: Remove the battery pack and memory card, leave camera while charging battery pack (or leave for a few minutes if you have a spare battery pack). Put in fully charged battery pack. If you get an error message about the memory card, shut down and replace card.

Try starting it with the OK or Function button pressed.

Place the camera on its back on a table, pointed at the ceiling. Press and hold the shutter button down, and at the same time press the power-on button. The idea is that the camera will try to autofocus while the lens is extending, hopefully seating the lens barrel guide pins in their slots.

Try these tips. Olympus seem to make pretty solid cameras -- I have two very secondhand ones, 3 and 5 years old and they function perfectly.
 
Thread starter Similar threads Forum Replies Date
A Digital Cameras 1
S Digital Cameras 1
A Digital Cameras 1
G Digital Cameras 0
L Digital Cameras 1
G Digital Cameras 0
D Digital Cameras 3
P Digital Cameras 6
G Digital Cameras 0
J Digital Cameras 1
M Digital Cameras 6
N Digital Cameras 1
S Digital Cameras 3
Q Digital Cameras 6
M Digital Cameras 1
K Digital Cameras 1
A Digital Cameras 1
C Digital Cameras 1
O Digital Cameras 1
L Digital Cameras 1

ASK THE COMMUNITY