PC is not using the full wifi speed

Aug 16, 2018
3
0
10
0
my dell inspiron 5520 which runs on windows 10 is not using the wifi internet connection properly , basically all other laptops are running way faster internet than my laptop in a same internet connection , there is no problems with the router settings and is not set as a metered connection
some 1 or 2 months back it was working fine in the same router and internet connection
it is using Intel Centrino wireless - N 2230 driver
 

Saga Lout

Olde English
Moderator
Take a look in Control Panel>Device Manager>Network Adapters to find the wi-fi adapter and see if there's a tick in the box under Power Management to allow the device to turn it off. Then, look in the Advanced tab and see if Wireless Mode is the same as any other system in your entwork.

I have to add that in Windows 10, the way to get to the Control Panel is to press the Windows key and R together then in the Run box type
control
and hit Enter. Then create a Desktop shortcut for it. MS only wants you to use Settings. Apologies if you already knew this.
 

Lutfij

Splendid
Moderator
A| It's possible that all the other devices are pulling the data and you're left with a portion of the bandwidth allocation from the router.
B| You may want to uninstall and reinstall your wireless adapter's drivers and see if the issue is resolved.
C| You may want to make sure you're on the latest BIOS update for your laptop.
D| What wireless adapters are the rest of your devices equipped with(in order to understand if you're atop of the pecking order)?
 

Saga Lout

Olde English
Moderator
Take a look in Control Panel>Device Manager>Network Adapters to find the wi-fi adapter and see if there's a tick in the box under Power Management to allow the device to turn it off. Then, look in the Advanced tab and see if Wireless Mode is the same as any other system in your entwork.

I have to add that in Windows 10, the way to get to the Control Panel is to press the Windows key and R together then in the Run box type
control
and hit Enter. Then create a Desktop shortcut for it. MS only wants you to use Settings. Apologies if you already knew this.
 
Thread starter Similar threads Forum Replies Date
P Laptop Tech Support 1
N Laptop Tech Support 9
V Laptop Tech Support 0
king-slim Laptop Tech Support 4
S Laptop Tech Support 2
D Laptop Tech Support 4
R Laptop Tech Support 3
S Laptop Tech Support 7
Bandead Laptop Tech Support 1
J Laptop Tech Support 0
P Laptop Tech Support 0
B Laptop Tech Support 3
A Laptop Tech Support 1
K Laptop Tech Support 8
H Laptop Tech Support 2
T Laptop Tech Support 4
M Laptop Tech Support 1
M Laptop Tech Support 1
R Laptop Tech Support 0
R Laptop Tech Support 1

ASK THE COMMUNITY