Question Pioneer VSX-930 "Amp Err"

David_647

Estimable
Mar 12, 2017
1
0
4,510
0
So about a week ago I was playing some games on my PC with the audio and video going through my AVR (a VSX-930) when I heard a pop on my rear/surround right speaker (I was using it in 5. 1 config) the amp shut down for a second and powered on again and I heard another pop, then the AVR DISPLAYED "Amp Err" on the display and wouldn't power on normally (MCACC light flashing) I tried resetting it by holding down the tune down button and the multi zone on off button and the error appeared again.
After that I uno lugged the amp and tried again only to get the same error.
Even though it was at night and I was running it fairly quiet (about - 40dB) with the same speakers I've had for years (Three 8 ohm speakers two made by B&W and one by Tannoy and two 6 ohm speakers made by DALI) I assumed it was the usual issue of a blown amplification transistor, however I initially took the amplification board off and tried to power on to see what error I would get (I got amp err) and after that the wireless light started flashing instead and the device was no longer in lockout mode, I could turn it on if I wished, even after reconnecting the amp board but it would always turn off after one or two seconds with "amp err" being displayed briefly.
So I took every one of the transistors out of circuit and tested them with a multimeter first to check for shorts (there were none) then one of those component testers that tells you what the component is and it's values and all the NPN and PNP transistors showed up as working transistors with values within the (fairly cheap) component testers error margin. In other words all amp transistors appear to be working.
So I checked the amp board and there didn't appear to be any cooked resistors, diodes or smaller transistors (it would have been easier if the board wasn't colored black) so I'm at a loss to what the issue could be.
Could it be an error with the logic board giving a false error or does "Amp Err" also show up when the preamp is broken? I did look deeper into the AVR and can see one very, very slightly bulged capacitor but it seems to be on the power delivery board. Everything else (that I can see as taking the whole thing apart will be a long and tough job) appears to be fine.

If anyone with more experience than me could point me in the right direction that would be great as I'm really at a loss as to what the problem is.
Thanks
-D
 
Thread starter Similar threads Forum Replies Date
Skye02 Audio 0
C Audio 0
Aindzheyan Audio 0
D Audio 1
fdakis Audio 1
S Audio 10
S Audio 0
GarethLittle Audio 0
M Audio 0
U Audio 3
B Audio 0
rainmakre Audio 0
E Audio 0
A Audio 0
Joevillabz Audio 3
Pipster Audio 1
C Audio 3
H Audio 0
S Audio 0
MySmartTVBox Audio 2
Similar threads
Question Help! Ffalcon Tv won’t output sound to pioneer amp
Question Looking for someone to clean and check over an old Pioneer car stereo system (cassette deck).
Question Pioneer SC-57 + LG UN9070 ARC issues
Question My Pioneer VSX-D514 will not power off after lightning surges last night, how can this be fixed
Question Pioneer VSX-45 Elite Receiver Only Displaying R & L Speakers
Question HDMI connection not permitted with Pioneer VSX-LX302
Question Remote ( AXD7692) not working on my pioneer vsx-828
Question Solenoid self-activating on Pioneer ct-1040w cassette deck
Question Pioneer VSX-44 Elite audio issues
Question Can you setup a Pioneer TX-6200 Pioneer tuner to a Harmon Kardon 3490 amp
Question Pioneer VSX-60 remote no longer connects with receiver
Question No auxiliary input on receiver (pioneer vsx-515-k)
Question Pioneer DJ DM-40 speakers just stopped working.
Question Sony 900h, pioneer VSX-933, PS5 - ARC not working
Solved! How to connect digital bass processor hifonics? I have pioneer avh head unit with built in crossover. Higonics manual says digital bass processor must
Solved! Pioneer 6500 amp to pioneer teap deck with vu meter
Solved! Pioneer sx-316 subwoofer channel fading
Question My Pioneer XC-HM82 does not power up
Question Pioneer VSX-51 Error UE33. I know it is a firmware update but I cannot find. Says there is one, but cannot get. HELP?
Question My Pioneer Receiver VSX-831 does not turn on. Network/Wireless red led light blinks erratically

ASK THE COMMUNITY