Plugged in universal power supply w/ volt selection and lost power.

zunigast

Estimable
Nov 24, 2014
1
0
4,510
0
Plugged in universal power supply w/ volt selection up to 12v w/universal tip and might have had it reversed.
Pluged it in and it shut off and wouldn't restart (no power). Took apart at later time by disconnecting the parts, plugged it in and it powered on so put "all" back together, plugged in and nothing.
Don't know what I did right or wrong but I tried to repeat at a later time and nothing at all.
HELP
 

hang-the-9

Titan
Moderator
Try it without the battery. You may have killed the charger port or the motherboard if you had something plugged in wrong on the power supply. If it won't turn on even without the battery, try unplugging the battery, unplug wall power and hold in the power button for 30 seconds, try again on only wall power. Use the original power supply not the universal one just to rule that out as an issue.

If that does not work, need to have the motherboard look at to repace the power connector or the motherboard itself.
 

hang-the-9

Titan
Moderator
Try it without the battery. You may have killed the charger port or the motherboard if you had something plugged in wrong on the power supply. If it won't turn on even without the battery, try unplugging the battery, unplug wall power and hold in the power button for 30 seconds, try again on only wall power. Use the original power supply not the universal one just to rule that out as an issue.

If that does not work, need to have the motherboard look at to repace the power connector or the motherboard itself.
 
Thread starter Similar threads Forum Replies Date
F Laptop Tech Support 1
nerdyotter Laptop Tech Support 0
Romanio0089 Laptop Tech Support 5
M Laptop Tech Support 7
Lucky247 Laptop Tech Support 0
Pentovillianking Laptop Tech Support 1
F Laptop Tech Support 5
Y Laptop Tech Support 1
Pandofla Laptop Tech Support 2
Sherry3scott Laptop Tech Support 1
Y Laptop Tech Support 1
M Laptop Tech Support 3
ChizDawg211 Laptop Tech Support 1
K Laptop Tech Support 14
IsaacSmith423 Laptop Tech Support 7
nitsu14 Laptop Tech Support 4
S Laptop Tech Support 2
N Laptop Tech Support 15
L Laptop Tech Support 1
T Laptop Tech Support 1
Similar threads
Question Mouse doesn't work when headphones are plugged in. Headphones don't work at all.
Question Battery slowly drains when plugged in; Won't run on just AC power
Question ASUS UX31A won't start. Black screen, no LEDs, buzzing sound coming from motherboard when AC adapter is plugged in.
Solved! Fps in-game starts decreasing after plugging and also unplugging AC cable
Question Laptop lags while gaming when charger is plugged in
Question when i plug an ear/headphone into the audio jack into my laptop, it works for like 3-10 minutes and then all of a sudden it stops working.
Question why does only the sound work and not my mic when i plug in my headphones to my laptop?
Question battery will not charge just says 0 percent plugged in
Question Laptop significantly slows down while charging/plugged in
Question Toshiba laptop goes into sleep mode while plugged in.
Question Run laptop in Battery Mode even when plugged to reduce CPU & GPU temperature
Question Laptop turns off when unplugged, screen wont turn on when plugged with no battery
Question Lenovo laptop plugged in, charging but battery percentage is not increasing.
Question internal laptop mic disabled when i plug in headphones
Question Laptop stutters when i play games plugged in
Question Laptop screen won't turn on only when plugged in
Question Plugged in, not charging
Question Laptop Built in battery plugged in suddenly reboots and it takes long to start again...battery showing 99% before it reboots
Laptop Battery 0% Available (Plugged in, Charging), When Connected to Universal Charger
I just got given a Toshiba satellite laptop had to buy a universal power supply I plugged it in but it won't power up or show

ASK THE COMMUNITY