Radio Signal Dropping out on Yamaha RX-V673

Suomitractorboy

Commendable
Feb 19, 2016
2
0
1,510
0
Over the last 3 months or so, the FM Radio signal has been dropping out intermittently on my Yamaha RX-V673 AV Receiver with the Radio and speaker icons disappearing from the display. To prove that it is not a signal or aerial issue (it is connected to a proper FM aerial via a coax cable), I have connected another amp and speaker to the aerial simultaneously using a splitter and when the signal drops out on the 673, it is still fine on the other AV amp. This suggests that it is an issue with the Amp but I was wondering if there is anything I can do without taking it to a repair centre. Any help would be appreciated.
 
Does this happen on more than one and strong stations?
One tuner may be more sensitive than the other so the signal could be lost on one and not the other. An older receiver may have a better tuner.
If it happens on more than one strong station the receiver is likely to need repair.
 
Does this happen on more than one and strong stations?
One tuner may be more sensitive than the other so the signal could be lost on one and not the other. An older receiver may have a better tuner.
If it happens on more than one strong station the receiver is likely to need repair.
 

Suomitractorboy

Commendable
Feb 19, 2016
2
0
1,510
0
Brilliant, thank you so much. Looks like it is a signal issue as other more local stations do not have this issue so will try it wilth a signal booster.

Thank you for taking the time to reply and educating me on this, it is really appreciated
 
Thread starter Similar threads Forum Replies Date
superbob0522 Audio 2
T Audio 0
D Audio 5
C Audio 1
I Audio 3
L Audio 3
B Audio 1
ronczap Audio 185
J Audio 3
P Audio 3
D Audio 1
D Audio 2
H Audio 1
J Audio 1
C Audio 7
A Audio 1
G Audio 2
J Audio 2
C Audio 1
B Audio 47

ASK THE COMMUNITY