Razer Kraken 7.1 no Sound, but on

VanillaDomo

Estimable
Jan 4, 2015
1
0
4,510
0
So my headset has been working for the past several months I had it for. Now my headset doesn't create sound when I am watching a video online, listening to music from Windows Media Player or in game. But when I use Razer Synapse 2.0 to calibrate it, there is sound. The LEDs are on so I am a bit confused. I tried restarting my computer, and tried different usb ports. I will put some screenshots of the settings.

Razer Kraken Mixer: http://prntscr.com/5og89p

Razer Synapse: http://prntscr.com/5og98j

Devices: http://prntscr.com/5og9ps

Playback settings: http://prntscr.com/5ogb3t




 

SkyBill40

Honorable
Oct 11, 2013
180
0
10,760
33
Do you also have speakers hooked up via USB, for example? I do. Each time I want to use my Kraken 7.1 I have to go to my Windows sound options and then change the Kraken to the default audio device for playback. You may need to do the same.
 

Gilbert Villarin

Estimable
Jan 25, 2015
1
0
4,510
0


hi, i have the same problem. i made it default audio but still nothing happen. everytime i calibrate it, i hear the calibration sounds but if i play any applications with sounds, the kraken headset is not working.
 

SkyBill40

Honorable
Oct 11, 2013
180
0
10,760
33
Your best bet may be to completely uninstall Synapse and then re-install it. When I bought my headset and even though I had the most recent version of Synapse, it didn't pick up my headset correctly. I had to go back to Razer's site and download the correct driver for it. I can't say that this is what you may have to do to make it work, but it's worth a try.

As for calibrating it, you should only have to do that once. Even if I go from my headset to my desktop speakers and back, no re-calibration is required; however, I DO have to change the default setting as I've explained above.
 

Pilotron

Estimable
Feb 5, 2015
1
0
4,510
0
I'm having the exact problem you're having with my razer kraken 7.1 chroma. one day they were fine now i can hear the calibration sounds and spotify but nothing else. I've contacted Razer however nothing has made it right yet. Wish i could find someone who could help us out because this is really starting to stress me out :p
 

JustinRowley

Estimable
Feb 21, 2015
1
0
4,510
0
Razer synapse might of muted the applications you want to use, go in synapse then go to mixer and on an application if there is noise coming from that application you should be able to see if something is muted or not, (speaker with red line through it) a while ago there was an update and all of a sudden every application I had was muted so I had to open applications that use sound and unmute them
 

bloody168

Estimable
Mar 12, 2015
2
0
4,510
0
i had the same problem i fixed it by going in task manerger>process and in there was a program called kraken helper ended that task. And sound worked. ps u have to restart programs such as skype to get the sound to work. Problem is now everytime i restart my computer i have to do this.
 

rafhay101

Estimable
Apr 1, 2015
1
0
4,510
0


When you're in task manager, try clicking on the "start up" tab and disabling the kraken helper thing.

 

zaebawski

Estimable
Apr 23, 2015
1
0
4,510
0
Halooo. I've met the same problem and found that for some crazy reason, I've got disabled sound for particular application in synapse sound mixer. The sound was enabled in windows audio mixer for e.g. Firefox, but in the synapse it was disabled!
So solution for me is the following:
1. Start your application which produces sound
2. Open your Razer Synapse
3. Go to Mixer tab
4. Check whether it muted. If muted, unmute

Hope this will help.

PS
I'd not recommend disabling/kiling kraken helper. Because it start treat sound in a bad way after that. Sound starts 'floating'.
 

skywere

Honorable
Dec 7, 2013
10
0
10,570
1


Lol this solved my problem xD
I used Audacity and suddenly my Kraken stopped working.

 

poisonedyouth

Estimable
Aug 2, 2015
1
0
4,510
0
Ok here is what I did to solve all the problems i was having with the Kraken 7.1 Chroma. Its a fantastic headset but imo Synapse isnt the most friendly or stable program.

1) Fresh install Synapse and reboot
2) Go into msconfig and in the startup disable KrakenHelper (look in startup tab in task manager for win 8.1)
3) reboot
4) Set the Kraken headset as default playback and communication device

Now check in device manager if the driver is the proper Razer Inc signed driver.
The problem I had was it was installing a generic Microsoft USB Headphone driver.
The driver files should be in C:\Program Files (x86)\Razer\
Update the driver manually here

Following this procedure my Kraken 7.1 Chroma is now working flawlessly under Windows 8.1

Hope this helps someone
 

replaysMike

Estimable
Jan 29, 2016
1
0
4,510
0


Wow this totally works!
 

DEEKSHEN

Commendable
Mar 21, 2016
1
0
1,510
0
Hi I have the same dumb problem the light is on but the sound is off i don't know what to do i think ill buy another headset and that's sucks
 

teunknip99

Commendable
Apr 3, 2016
1
0
1,510
0
For mac users: go to system preferences>Sound, and select the kraken headset you want to use. this may be similiar with windows users. there might also be problems with the mic but thats because you also need to select that one in Sound settings
 

marcolinococolino

Commendable
Oct 5, 2016
2
0
1,510
0


 

marcolinococolino

Commendable
Oct 5, 2016
2
0
1,510
0
Dude. I just updated my razer synapse in the morning and now I cant hear shit, but my mic is working... I have razer kraken pro. Idk what to do cause my souns works on skype but on yt videos or ingame is not.
 
Thread starter Similar threads Forum Replies Date
S Audio 0
O Audio 1
H Audio 2
L Audio 1
S Audio 10
S Audio 1
I Audio 7
A Audio 4
Z Audio 1
T Audio 1
E Audio 2
X Audio 2
B Audio 3
B Audio 3
S Audio 17
P Audio 2
DoYouLikeMelon Audio 5
M Audio 1
N Audio 3
S Audio 6

ASK THE COMMUNITY

TRENDING THREADS