Solved! RCA MAVEN PRO unable to complete bootup

Oct 21, 2018
2
0
10
0
When I mash the power button on, the tablet opens the first screen showing the two dogs near the Victrola player. When it opens to the screen showing the Maven Pro logo, it stays there until it runs out of charge. I tried rebooting many times to no avail. It stays on the logo screen. Period. Only movement I see is the shadow that scrolls over the logo. What can I do to fix it? I've had the tablet for about 2 years.
 
Try starting it up in "Safe Mode" and see if it will load. If it does, then you have something on the device that is the cause. Bad app, malware, virus, etc., that will need to be removed for you to use the device normally. If, however, it still won't load even in "Safe Mode", then you are looking at either a "Hard Reset" or having repair work done on the device by a tech.

To get into "Safe Mode" please do the following.

1. First turn off the tablet.

2. Next press and hold "Power" until you see the manufacturers logo on the screen, then release the power button.

3. "Quickly" press "Volume Down" and hold it for few seconds until you see the message "Safe mode: ON" or something similar.

4. If you wanted disable it, simply repeat the steps above, and you should see "Safe Mode: OFF" rather than on.
 

ASK THE COMMUNITY