RCA Pro 10 tablet stopped working


Mar 20, 2016
I got the RCA Pro 10 tablet with a case about 6 or so months ago and it was working perfectly fine. Until a couple days ago where it just stopped working. I've tried using the rest button and it didn't help.
Have you tried checking the battery? Although you are charging it (I am assuming that you are) it still could have died. Try the battery in another device (if you can) and I would consider purchasing a new battery.

If that doesn't work, you could try a "Hard Reset", but this is really only a last resort option, as you will lose your data if you do it. Should you choose to do it, here are the instructions.

To "Hard Reset" the tablet...

1. Make sure that the tablet is actually powered off.

2. Press the "Power" and the "Volume Up" buttons, together, until you see the start-up logo on the screen.

3. Once you can see the logo, release the buttons and allow the device to enter the "System Recovery Mode".

4. Next use "Volume Down" button to get to the "wipe data/factory reset" option When in recovery mode the "Volume Up" and "Volume Down" buttons are how to can navigate and highlight what option you need.

5. Once you have selected the "wipe data/factory reset", press the "Power" button to select that option.

6. On the following screen, repeatedly press the "Volume Down" button until the "Yes - delete all user data" option is what is selected.

7. Then press the "Power" button to hard reset the tablet.