RCA tablet help needed!

Soarablacktiger1

Commendable
Jun 8, 2016
4
0
1,510
0
I have an RCA tablet, model number RCT6203W46, and it is refusing to load for me. I push the button to turn it on, and it starts up going to the white screen with the dogs, and never leaving it. I have tried to factory reset it, but I haven't been able to get it to go to the screen where I have the option to do that. Please help!
 

Saga Lout

Olde English
Moderator
Turn it off the press the power button to turn it back on but also press the volume down button at the same time. That offers you the recovery options. You scroll through them using the volume buttons and select one by the power.
 

Saga Lout

Olde English
Moderator
Sorry - my bad. It seems you see tose dogs Nipper and Chiper when you load that screen and on that model it's the Volume Up button you need not the Down one.

Press that first while the machine is turned completely off then press the Power button at the same time and you should see the dogs.

From here on, this is helpful. I don't make a habit of referring posters to YouTube videos but this guy seems quite well informed and he tells it quicker than I can write it. https://www.youtube.com/watch?v=ttvFDFqH5r0
 
Thread starter Similar threads Forum Replies Date
J Android Tablets 4
E Android Tablets 0
TaroBeni Android Tablets 4
ZambieMaster Android Tablets 3
Xjock21 Android Tablets 1
Southtxmunkey Android Tablets 3
Sia111 Android Tablets 6
D Android Tablets 2
K Android Tablets 1
B Android Tablets 8
V Android Tablets 2
H Android Tablets 3
C Android Tablets 2
D Android Tablets 1
K Android Tablets 1
R Android Tablets 2
T Android Tablets 1
N Android Tablets 1
S Android Tablets 1
M Android Tablets 1
Similar threads
Question Budget Tablet For Specific Needs
Question Help from you clever lot - need an 'in the meantime tablet' Fire HD 10, Lenovo M10, Huawei MediaPad T5 or other??? ...
Question I need help, My tablet (rca voyager rct 6973w43), just show me the logo an after a message red letter that says Bootloader error code 1 when turn on
Solved! Need some serious help with my tablet (can't install/ uninstall anything)
Question Packard bell Airbook tablet M10500 Need help with keyboard etc. Does not work. Tried everything. Its detachable
Question I just bought a samsung tablet E from a pawn shop ,have the receipt and they factory reset it for me but got home it said it needs the previous email
Question Need Help, Android tablet stuck in loading screen
Question I need an Android tablet, preferably 7" class with 2 simultaneous USB connections
i need a unlock code for a aqt80 from sprint
Solved! Tablet needs help
Solved! Need a help to make my tab work
Need help upgrading an abandoned tablet.
Solved! need help with noise app requires andriod 4.4 or higher
Yes I have the tablet next book.now my owner of the property forgot password so I have to sign under guess. What do I need to
Need help with broken charging port
Trying to watch a movie on REC Tablet need to set size
i have rca voyager 3 tablet it wont let me do anything it is saying "system UI has stopped" need help
Need help please
I bought a voyager 3 off of someone and they reset it but now I can't use the tablet. It keeps telling me that I need to use a
Need a review on RCA tablet

ASK THE COMMUNITY