ROG Zephyrus GX501 charger doesn't work 99% of the time

CrimStar

Estimable
Jul 28, 2015
3
0
4,510
0
My ASUS Zephyrus GX501 has a big issue. While in vacation with family when I went to plug it in nothing happened. There wasn't even an orange charging light. I tried multiple outlets in the house but no matter what I couldn't get it to work. I contacted ASUS support and they said I needed to RMA it. I decided to put it off and just enjoy Thanksgiving. When I got back to my apartment however, I decided to try plugging it in again and it suddenly worked. I played games on it for a couple hours and got some work done, then shut it down, put it in my bag, and went to bed. When I woke up I pulled it out and plugged it in, only to have the exact same problem as before. I depend on this for school and work so sending it in for 2 weeks to get repaired really isn't a good option for me. Any help at all would very much be appreciated.
 
Thread starter Similar threads Forum Replies Date
J Laptop Tech Support 1
B Laptop Tech Support 2
S Laptop Tech Support 1
T Laptop Tech Support 1
P Laptop Tech Support 0
superpeas Laptop Tech Support 2
Philipowl Laptop Tech Support 0
lin1614 Laptop Tech Support 2
P Laptop Tech Support 3
applepai96 Laptop Tech Support 0
A Laptop Tech Support 0
Lucky247 Laptop Tech Support 0
Toastbyte Laptop Tech Support 1
Mdot Laptop Tech Support 1
JohnDoer Laptop Tech Support 11
L Laptop Tech Support 1
Benzbody Laptop Tech Support 6
viperbj Laptop Tech Support 1
Icedkopee Laptop Tech Support 1
NESHAKY Laptop Tech Support 0

ASK THE COMMUNITY