Sager 9150 w/AMD 7970m help

f16wannabe

Honorable
Nov 4, 2012
3
0
10,510
0
Hello Forum,

I just recently received my brand new laptop from Xoticpc.com the other day and I'm pleased with the speed of it and how it looks and feels. The problem I am having is I upgraded it to Windows 8 Pro for 15$ and I'm having problems with the graphics switching. When I try out games like BF3 I have to use Medium settings or the computer lags significantly which makes me believe the graphics are on the Intel 4000 and not the AMD 7970. Also when I play Napoleon Total War or Shogun 2 Total War it shows the graphic card in use in the options which states the Intel 4000. I just recently found out that people are having a lot of trouble with the graphics switching but I haven't found a fix and was wondering if anyone knows of a fix for the 7970m with Windows 8. I have all the drivers up to date and also installed the AMD latest beta drivers that were released a few days ago. Nothing seems to work and the graphics are on medium but when I see others playing on there systems on YouTube I see them with their settings on Ultra with the same computer. The reason why I spent 1700$ on this laptop was for the graphics to be on high since I'm an airline pilot and always on the road, I can't have a desktop to haul around the airport. Any help or direction would be greatly appreciated. Thank you for your time.

Robert
 
Thread starter Similar threads Forum Replies Date
W Laptop Tech Support 0
qamar198 Laptop Tech Support 4
B Laptop Tech Support 1
P Laptop Tech Support 1
X Laptop Tech Support 4
W Laptop Tech Support 7
A Laptop Tech Support 2
M Laptop Tech Support 23
M Laptop Tech Support 8
B Laptop Tech Support 6
R Laptop Tech Support 3
C Laptop Tech Support 1
D Laptop Tech Support 1
V Laptop Tech Support 1
S Laptop Tech Support 1
C Laptop Tech Support 2
B Laptop Tech Support 1
Z Laptop Tech Support 5
M Laptop Tech Support 4
F Laptop Tech Support 2

ASK THE COMMUNITY