Question Samsung Notebook 9 ignores USB 2.0 devices connected to USB-C hubs

Aug 10, 2021
1
0
10
0
Hi,

I have a np900x5t-x01us Samsung Notebook 9 (https://www.samsung.com/us/computing/windows-laptops/notebook-series-9/notebook-9-15--np900x5t-x01us/)

It has a Thunderbolt 3 port that works for charging and connecting USB-C devices, but it has a weird issue with thunderbolt/usb-c hubs. Passthrough charging works. Video works with both HDMI and VGA ports on hubs. Connecting USB 3 devices to USB 3 ports on hubs generally works (Most devices are fine. I found an external DVD drive that was powered, but didn't work.) But plug a USB 2 device into a USB 3 or USB 2 port on a hub, and it won't be recognized at all by the computer. The same goes for plugging things into ethernet ports, audio output ports, and card reader ports. Plug the same USB 2 device (or audio output or microSD card) into the computer directly, and it works fine.

I've tried 3 different hubs from 3 different manufacturers. All of the ports on all of them work fine when connected to a Dell Inspiron, an IBM ThinkPad, and an Apple Macbook Pro, but all 3 have the same issues on the Samsung. Power, video, and USB 3 devices work. Nothing else does.

Device Manager shows no errors. In the controller section, the default is:
  • Intel (R) USB 3.0 eXtensible Host Controller - 1.0 (Microsoft)
  • USB Composite Device
  • USB Root Hub (USB 3.0)
Plugging in a simple hub with just USB-c power pass through, VGA, and one USB 3 adds:
  • Generic SuperSpeed USB Hub
  • Intel(R) USB 3.1 eXtensible Host Controller - 1.10 (Microsoft)
  • USB Root Hub (USB 3.0)
A USB 3.0 hard drive plugged into that hub's USB 3 port works fine. The nice you-plugged-in-a-device sound and the Device Manager refreshes with the new device.

If a USB 2 mouse, keyboard, wifi dongle, or flash drive is plugged in, there's no sound, no update to Device Manager, and no power going to the peripheral. Plug the same peripheral into the laptop directly, and it works properly (sound, update, power, usable).


I've tried the usual standard steps:
  • Making sure all Windows Update and Samsung Updates are applied.
  • Updating drivers (all say they are up to date)
  • Disabling all USB controller and connector drivers, restarting, enabling, restarting.
  • Uninstalling drivers, restarting, reinstalling, restarting.
  • Restarting in safe mode.
  • Updating machine firmware, restarting.
  • Poking around in the BIOS looking for a setting like "ENABLE ALL PORTS ON USB-C/THUNDERBOLT-3 HUBS"
  • I have not recently done a system recovery, but I previously did one. The issue existed before the recovery and afterwards.
Any other ideas of what to try? Samsung Support was very unhelpful. They decided that the hubs must be bad, and I should just plug the devices into the computer directly.

Yes, this computer is a couple years old. It has always had this issue. At first I thought it was just the hub I had. More recently, I acquired new hubs that still had the issue, and now my use case has changed so that a hub would be extremely helpful.

Thanks!
-Kevin
 
Thread starter Similar threads Forum Replies Date
T Laptop Tech Support 3
S Laptop Tech Support 1
Peter M. Laptop Tech Support 2
F Laptop Tech Support 4
P Laptop Tech Support 5
B Laptop Tech Support 3
A Laptop Tech Support 5
C Laptop Tech Support 9
G Laptop Tech Support 1
A Laptop Tech Support 1
K Laptop Tech Support 2
R Laptop Tech Support 6
F Laptop Tech Support 1
A Laptop Tech Support 1
H Laptop Tech Support 1
Megzari Nassim Laptop Tech Support 5
V Laptop Tech Support 1
B Laptop Tech Support 3
Y Laptop Tech Support 3
B Laptop Tech Support 1

ASK THE COMMUNITY