Question Samsung UE40D5520 (boot loop?)

ItsAlpey

Estimable
Sep 12, 2015
1
0
4,510
0
Hello,

I’ve had this TV for years now (VERY light usage maybe 10h/week) and it’s finally come to the end.

From my Google searches it appears that the most common fault for this is the capacitors blow causing the almost-like bootloop. The issue I have is all the capacitors look fine (non split / burnt looking) apart from what I’m guessing is glue for the larger capacitors.

Link to photos;
View: https://imgur.com/gallery/aHwspYI


I had an aeriel plugged in yesterday and it showed the picture on the channel clear as day & played the sound perfectly for about 5 seconds before going off again. (Same thing for hours)

I’ve tried; re-seating all the cables, clearing of dust (very little), leaving a USB plugged in with the latest firmware on in hope it’d boot up & update, leaving an Ethernet plugged in as I read somewhere that the WiFi chip failed during an update & it was continuously trying to update still, made sure all the board screws were secure and tight and also tried the remote service menu inputs etc.

The remote nor the touch buttons on the tv itself actually do anything, they register (red light indicates that every time I press something) but nothing happens.

Completely lost at what else to try apart from a trip to the skip.

Any advice or recommendations are welcome :)
 
Thread starter Similar threads Forum Replies Date
M Streaming Video & TVs 0
S Streaming Video & TVs 1
N Streaming Video & TVs 0
harrisjb78 Streaming Video & TVs 0
mtp1032 Streaming Video & TVs 2
Loco_Gizmo Streaming Video & TVs 2
I Streaming Video & TVs 4
B Streaming Video & TVs 0
X Streaming Video & TVs 0
L Streaming Video & TVs 1
E Streaming Video & TVs 2
J Streaming Video & TVs 1
B Streaming Video & TVs 3
R Streaming Video & TVs 0
J Streaming Video & TVs 1
B Streaming Video & TVs 3
J Streaming Video & TVs 1
H Streaming Video & TVs 3
T Streaming Video & TVs 3
M Streaming Video & TVs 1

Similar threads


ASK THE COMMUNITY