Screen turns off randomly.

gaug90

Estimable
Sep 3, 2015
3
0
4,510
0
Hello.

I have a Dell XPS L502x, it has been working fine for a couple of years but I decided to upgrade from windows 8.1 to windows 10, there were some performance issues so I decided to format it and install windows 8.1 again, it was working fine apparently but then the screen started to turn off and on after a few seconds in a random way. I tried everything I could think off, updating the integrated video driver( because this laptop has 2 video cards, an Intel HD 3000 and NVIDIA one), downloading it from dell's official site, but nothing seems to work.

I entered the BIOS setup to see if theres any config that would help, but even when I was in the BIOS the screen would turn off for a few secs and then turn on again, I have to mention that when this happens the computer is still on and working, it's just the screen.

Do you have any idea what could be happening? when I disable the integrated drivers from Device Manager it seems to stop doing that, but I haven't tested long enough to be completely sure of that.

Thanks in advance for your help.
 
Hi,

The fact that the problem happens in BIOS as well it could be a possible hardware issue as well. But please do try to uninstall and reinstall the graphics card driver as well. Here are the steps:
- Uninstall the graphics card driver from Device Manager and in Programs and Features as well since it should have something related to NVIDIA in there as well.
- Once uninstalled download and install the latest driver from NVIDIA support site.
- Here's the link: nvidia.com/download/index.aspx
- Use the Auto Detect feature so they could give you the latest and accurate driver for your graphics card.
- Lastly reboot it once the latest driver has been installed.

If this doesn't solve the problem please do try to disable the Intel Graphics card in Device Manager and observe it. If does still happen, last thing you need to try is to perform a Factory Reset with the laptop.
 

gaug90

Estimable
Sep 3, 2015
3
0
4,510
0


Hello,

I tried that and it is still happening, there is one weird thing, I installed Windows 7 from scratch and it was working for some hours I was so happy, but I installed all the updates and the next day the issue came back, I thought some drivers installed so I just installed the same ones I was using before when it was working fine but still, the screen was the same, how do you do a factory reset?

EDIT: Some IT guy told me the issue was the integrated graphics so I had to replace the whole motherboard, what do you think? and if it's true is it worth it?

Regards.
 

gaug90

Estimable
Sep 3, 2015
3
0
4,510
0
Hello, as ffg7 suggested I used my TV for about an hour as the main monitor and it worked flawlessly, but when I extented monitors the problem presented in both of the displays, it was weird like if the laptop screen disconected and connected again because it messed up the screen resolution settings everytime, but once I closed the lid, windows displayed just fine on the TV, I even watched some videos and everything was fine.

As this test suggests it might just be my laptop screen and not the motherboard(hopefully) but is there any other test I can do to be completely sure? I'd hate to buy a new laptop screen if the problem is going to keep happening anyway.

Thanks in advance for your kind help.

Regards.
 
Thread starter Similar threads Forum Replies Date
S Laptop Tech Support 3
vsoodursun Laptop Tech Support 0
A Laptop Tech Support 0
S Laptop Tech Support 0
H Laptop Tech Support 8
jasonkariuki98 Laptop Tech Support 1
R Laptop Tech Support 3
lennium Laptop Tech Support 5
Naroa Laptop Tech Support 0
Tintha Laptop Tech Support 1
T Laptop Tech Support 3
Tilo Laptop Tech Support 1
A Laptop Tech Support 1
X Laptop Tech Support 3
R Laptop Tech Support 6
R Laptop Tech Support 3
B Laptop Tech Support 1
J Laptop Tech Support 3
J Laptop Tech Support 14
W Laptop Tech Support 3

ASK THE COMMUNITY