Sennheiser GAME ZERO sounding awful?

vFoxArts

Honorable
Jan 31, 2014
7
0
10,510
0
So my Sennheiser GAME ZERO arrived today, i was planing on replacing my HyperX Clouds because the leather was getting ripped apart and they were kinda old. So i plugged in the new game zero, went to soundcloud to test and they sound awful compared to my old headset. I don't think my motherboard onboard sound kills it because i have a Gigabyte GA-Z97X-UD3H-BK with decent onboard sound. They sound muddy and the bass feels super weak and dumped down. Any of you know anything about this? Or did i just order garbage?
 

vFoxArts

Honorable
Jan 31, 2014
7
0
10,510
0


Rear end. Just updated Mobo sounds drivers as well, didnt work. The thing that makes me wonder is that my HyperXclouds just sounded so much more alive and no so muddy like this hmmm. Really bothers me.
 

vFoxArts

Honorable
Jan 31, 2014
7
0
10,510
0


I don't have another source with such high-end sound specs, only an iphone 6s and a shitty Laptop from Acer lmao.
 

BringerOfTea

Estimable
Dec 17, 2015
75
0
4,610
10
then return them if you feel that the product didnt deliver its promise... :) though If you could get you hands on another source you might find the quality fine...
 

vFoxArts

Honorable
Jan 31, 2014
7
0
10,510
0


I was hoping someone here maybe had similar experiences with this headset. I'll try and test them out abit more before returing them, but my first impression when testing these for a few hours is very disappointing.
 

vFoxArts

Honorable
Jan 31, 2014
7
0
10,510
0


Sound just as bland on my phone as pc, perhaps i need an amp. Good call.
 

bloodroses

Honorable
Jan 27, 2013
19
0
10,570
1
I found this on Amazon's Q&A:

"In order to get the most out of these headphones, would I need a good sound card and/or a headphone amplifier?
Answer: Yes, most onboard solutions are not made to push 150 ohm cans.
Yes. One recommended setup is the 720 dac from Cypher."


They said the newer model runs at 50ohms instead of 150ohm. It is possible you got the older 150ohm model.


From an Amazon review:

"I just wanted to take the time to say this product is outdated the new G4ME Zero Cans on the Sennheiser site are 50 ohm not the 150 ohm shown here you no longer need an amp to push these cans, This was also confirmed with an email to Sennheiser Shown Below. Now Amazon needs to get the new Zeros, they want $250 on the Sennheiser site i'll just wait for the updated Zero's to hit Amazon.

New reply for the ticket #TS100053799

Yes the G4ME ZERO latest versions are now down to 50 ohms therefore bypassing the need of an amp. True the PC363D and G4ME ONE headsets are only offered in open back design.

Zachary Marquis

#TS100053799
Sennheiser USA Tech Support
Thank you,
Sennheiser Support Team"
 

vFoxArts

Honorable
Jan 31, 2014
7
0
10,510
0


Got the 50 Ohms ones

 

bloodroses

Honorable
Jan 27, 2013
19
0
10,570
1
I'd contact Sennheiser then since it sounds like you might have gotten a faulty pair. I use Sennheiser headphones myself (different models) and they've all sounded great. The nice thing is their service department is great as well. :)
 

vFoxArts

Honorable
Jan 31, 2014
7
0
10,510
0
Guys, it turns out its the volume wheel on the side of the headset that cucked me, turns out when you adjust it to low-medium volume it completely wreck the sound (even glitching it out making only one of the sides of the headset playing). Turning it all the way up fixed everthing. Not sure if i should send it back, it sounds fine now. Ty all for the help anyways :D
 
Thread starter Similar threads Forum Replies Date
T Audio 1
M Audio 10
M Audio 2
A Audio 9
M Audio 1
J Audio 7
A Audio 5
T Audio 6
R Audio 1
O Audio 12
W Audio 2
B Audio 1
O Audio 2
G Audio 2
N Audio 2
S Audio 1
J Audio 2
0 Audio 6
C Audio 1
chaos_viper15 Audio 5

ASK THE COMMUNITY