Some Headphones missing lows on Soundcard

Mitchell Robinson

Honorable
Sep 18, 2013
41
0
10,610
7
Hi guys,

Weird problem.

Just installed my Asus Xonar DG soundcard and took the PC to a friends to LAN. I was telling them about the soundcard and they all wanted to put their headphones onto the card to see how it compared. However, a few of the headsets provided strange results. My Sennheisers work fine on the card, but my friends Astro's and Monsters sound a lot quieter and have massively drowned out lows (Imagine the sound of some really cheap earbuds for like a buck).

I even went into my sound settings and changed all the settings around to make sure they were correct, i even tried some other settings, but still nothing changed.

Would love to know if there is an easy fix for this. I'm a bit worried because i just ordered some expensive headphones and dont want the same result.

Thanks
 

Kursun

Distinguished
Jan 6, 2008
50
0
18,610
7
All headphones have different sensitivities, and impedances. Drop of low frequencies is probably due to an impedance mismatch.
If you are really serious about headphones you should buy a dedicated headphone amplifier, preferably one that is a Class A amplifier design.
 

Kursun

Distinguished
Jan 6, 2008
50
0
18,610
7
All headphones have different sensitivities, and impedances. Drop of low frequencies is probably due to an impedance mismatch.
If you are really serious about headphones you should buy a dedicated headphone amplifier, preferably one that is a Class A amplifier design.
 
Thread starter Similar threads Forum Replies Date
randoom12 Audio 0
Kevfletcher1 Audio 5
Q Audio 1
W Audio 1
sdwda Audio 1
M Audio 1
V Audio 2
C Audio 1
K Audio 2
DiabolusGX Audio 0
R Audio 0
P Audio 2
S Audio 0
Smikeey Audio 0
M Audio 0
pleasehelpme12938 Audio 1
atesba Audio 3
T Audio 3
P Audio 0
L Audio 0

ASK THE COMMUNITY

TRENDING THREADS