Sony a6000 photos will NOT download to Mac via USB

gypsy guru

Prominent
Jul 15, 2017
3
0
510
0
I recently got a Sony a6000. First round of photos, connected camera to my Mac (El Capitan 10.6) and photos downloaded instantly, as with prior DSLR. Now trying to download a second set and nothing works. Tried a few suggestions from prior posts. Nada. Screen says "USB Mode Connecting..." But it does not. No action at all. Tried changing the USB mode to every option provided. Nada. Tried turning the camera on/off with the computer on/off. Nada. I really really do not want to even try the software interface Sony is pushing. And clearly, it isn't necessary as the first download worked perfectly. After 90 minutes, I'm at my wits end. (And I need my wits!) Suggestions???
 

gypsy guru

Prominent
Jul 15, 2017
3
0
510
0


 

gypsy guru

Prominent
Jul 15, 2017
3
0
510
0
THX Ken - great minds think alike! Exactly what I ended up doing.
Appreciate your time & suggestion. Still ... hoping someone out there has a viable solution.
 
Thread starter Similar threads Forum Replies Date
J Digital Cameras 0
M Digital Cameras 3
T Digital Cameras 5
M Digital Cameras 2
Z Digital Cameras 0
P Digital Cameras 2
S Digital Cameras 3
G Digital Cameras 0
4 Digital Cameras 1
G Digital Cameras 0
G Digital Cameras 0
G Digital Cameras 0
E Digital Cameras 3
D Digital Cameras 1
R Digital Cameras 11
S Digital Cameras 2
seancaptain Digital Cameras 0
seancaptain Digital Cameras 9
A Digital Cameras 4
G Digital Cameras 0

Similar threads


ASK THE COMMUNITY

TRENDING THREADS