Sony Vaio turns on no display fan spins

EclipseFTW

Commendable
Mar 19, 2016
2
0
1,510
0
Hello I recently got This Sony Vaio PCG-7311M laptop, the screen looks dead when I look closer. The odd thing is laptop turns on with OR without cpu inside and does same thing.Fan spins at normal speed after 10 seconds starts spinning to a maximum speed. Cant turn laptop off by holding power button, only by unplugging battery. Any ideas what might be causing this? Tried connecting throught TV through hdmi, didnt work. Unfortunately dont have vga cable, should I try getting one to connect to TV? Please help
 
Hi,

Here are some troubleshooting steps that may help.
- First is to do a hard reboot, remove the battery and unplug the AC adapter then press and hold the power button for 20 seconds then try booting it up again.
- If it will not work reseat the RAM's, remove them all for couple of seconds then put them back in making sure everything is seated properly into each RAM slot.
- Next is to try hooking it up onto an external monitor and see if you'll get any display from it. If it will not produce any display disconnect the ribbon cable that connects the built in display to the motherboard then try it again.
- If all these will not work the problem is the motherboard itself.
 
Hi,

Here are some troubleshooting steps that may help.
- First is to do a hard reboot, remove the battery and unplug the AC adapter then press and hold the power button for 20 seconds then try booting it up again.
- If it will not work reseat the RAM's, remove them all for couple of seconds then put them back in making sure everything is seated properly into each RAM slot.
- Next is to try hooking it up onto an external monitor and see if you'll get any display from it. If it will not produce any display disconnect the ribbon cable that connects the built in display to the motherboard then try it again.
- If all these will not work the problem is the motherboard itself.
 

EclipseFTW

Commendable
Mar 19, 2016
2
0
1,510
0
I've tried all of these before, as I said laptop does the same thing no matter what. External monitor doesnt show anything, also no light on internal screen. Figured it will most likely will be motherboard, just wanted to make sure. Thanks for reply :)
 
Thread starter Similar threads Forum Replies Date
abraracs Laptop Tech Support 5
Ioannis1981 Laptop Tech Support 8
slepong Laptop Tech Support 1
A Laptop Tech Support 0
F Laptop Tech Support 0
A Laptop Tech Support 14
H Laptop Tech Support 0
S Laptop Tech Support 3
T Laptop Tech Support 5
zyaxc Laptop Tech Support 3
T Laptop Tech Support 2
M Laptop Tech Support 1
X Laptop Tech Support 3
Y Laptop Tech Support 3
S Laptop Tech Support 1
T Laptop Tech Support 1
C Laptop Tech Support 2
A Laptop Tech Support 3
H Laptop Tech Support 1
M Laptop Tech Support 1

ASK THE COMMUNITY