Sony Vaio VGN-SZ56GN Can't find Nvidia 8400m GS Driver

Goodra

Honorable
Jan 3, 2014
6
0
10,510
0
The HDD died on my Vaio today, So I installed a new one and reinstalled Windows 8.1 on it only to discover that the 8400m GS was not detected. Instead, I get the "Microsoft Basic Display Adapter" instead of the Nvidia graphics chip. I cannot for the life of me find the driver for it. I went on Sony's website, But there was no display driver for Windows 8.1. Oddly enough, On my old HDD, It was working flawlessly. But now, Nothing. I even tried using a Windows Vista version of the driver, But it refused to install. Tried the GeForce Experience and it couldn't detect the graphics chip either. Even went on Nvidia's website to manually find the driver, And it wouldn't install either. Is this thing doomed to forever be using the GMA x3100? The laptop is in "SPEED" mode also, So there is no excuse for the card to not be working. The card couldn't be dead either, as when I look at the screen resolution are and go to adapter, It shows the card like this.

Adapter Type
Microsoft Basic Display Adapter
Chip Type: NVIDIA
DAC Type: NVIDIA Corporation
Adapter String: Microsoft Basic Display Adapter
Bios Information: 686 Board - e415hsz1
Total Available Graphics Memory: 256 MB
System Video Memory: 0 MB
Shared System memory: 256 MB

The card however, is not shown or even mentioned in the device manager. I don't know what to do.

Help would be much appreciated.
 

geofelt

Distinguished
Oct 9, 2006
647
0
19,910
171
Install ALL of the drivers available for your laptop.
There may be something that is not enabling the "speed" switch.
Make certain that there are no ! in the device manager listing.
 

geofelt

Distinguished
Oct 9, 2006
647
0
19,910
171
Install ALL of the drivers available for your laptop.
There may be something that is not enabling the "speed" switch.
Make certain that there are no ! in the device manager listing.
 

Goodra

Honorable
Jan 3, 2014
6
0
10,510
0


Had to use a driver program. Installed the drivers and it worked! Thanks!
 

harrawal

Estimable
Jul 2, 2014
1
0
4,510
0


Bro I have the same problem, can you give me the link for the program as well please?
Thanks

 
Thread starter Similar threads Forum Replies Date
A Laptop Tech Support 1
GJG10 Laptop Tech Support 0
The MSI Guy Laptop Tech Support 1
A Laptop Tech Support 0
M Laptop Tech Support 1
D Laptop Tech Support 0
U Laptop Tech Support 1
M Laptop Tech Support 1
D Laptop Tech Support 10
Jabeabus Laptop Tech Support 1
ObaiSukar Laptop Tech Support 1
A Laptop Tech Support 1
Secritek Laptop Tech Support 3
I Laptop Tech Support 0
Nitesh Poonia Laptop Tech Support 1
R Laptop Tech Support 0
Lartwel Laptop Tech Support 1
Srijal Kc Laptop Tech Support 2
NOOB2PRO Laptop Tech Support 2
V Laptop Tech Support 5

ASK THE COMMUNITY