Speaker System Wont Work When Plugged Into PC (Cambridge Soundworks Microworks II)

Dylan Hammer

Oct 6, 2013
I am at my wits end here. I recently dragged the old Cambridge speaker system I had out from the basement, since I needed a home audio system and didnt want to spend alot of money. I got the speakers wired up and running, and when I plugged them into my Iphone, the sound came out loud and clear. The trouble starts when i tried to plug them into my desktop PC. No matter what I did, they didnt make a sound. Now, I have a headset also plugged into the computer at the same time (an Astro A40, taking up a USB and the optical audio port), so I thought that might have been the problem, so I unplugged that, but the speakers still wouldnt play. When i go to sound settings, I can see the Astro headset, and another one that just says "headphones". Setting it to default doesn't do anything though.That one only uses the LR audio jack.Then there's a last one that says "Speakers", but it is completely unusable; I cant use the test button on it, and setting it to default does nothing either. Now, I thought it might have been my LR jack that was broken, so I plugged my apple earbuds into them, and found that I could get audio from those, but still not from the speakers. I think this may slowly be driving me insane, so any help would be appreciated.

(oh, I dont know if this will help, but I have an ASRock 970 EXTREME3 motherboard)