Speakers only play properly in Stereo

Torroan

Estimable
Nov 7, 2014
3
0
4,510
0
Hello guys,

I have the Logitech X-540 5.1 Surround Sound Speaker System and while everything is properly connected it only plays in Stereo(All speakers produce sound). However on 5.1 only the central speakers work and the others do not operate at all. I checked the cables to see if the issue laid there but it seems that it's not faulty cables. Also the issue does not like in the motherboard receivers aswell since i've used another motherboard to test aswell.
I would very much appreciate your help.

Thank you in advance
 

Gingerbread

Distinguished
Nov 2, 2009
248
0
19,110
58
When you set your configuration to 5.1 in the Realtek driver or whatever you are using and you click on each individual speaker in the driver management, do you hear sound from each of them, or they produce no sound?
 

Torroan

Estimable
Nov 7, 2014
3
0
4,510
0
No there is no sound coming from other speakers neither when i click test nor when i click each one individualy. Moreover in stereo mode each and everyone of the speakers produce sound as stated before.
 

ssddx

Glorious
Moderator
you can manually check if the speaker system is fine by plugging (one at a time) the green then yellow then black cables from the system into your pc headphone jack with it set to 2.0 and then doing a speaker test. if your speaker system on each test works for both speakers (FL+FR, CEN+SUB, RL+RR) then its working fine and its your pc or settings that are the issue. if it fails these tests then something odd is going on with the set internally although the only thing inside there is an amplifier so i can not see why it would fail to work outside of an amp failure (but since you listed all speakers working this can not be the case).

on stereo sound all speakers should not be firing unless you enabled external stereo mode or similar which duplicates the front to the rear (this is something you would have to manually set). otherwise 2.0 sound will come out the left and right speakers along with the subwoofer. in some cases your front center as well but the rears would be dead. the only time you will get sound out the rear is on 5.1 content or if you duplicated the front to the rears.

you say "central speakers work". what is this? since you said speakers plural i am guessing you did not mean "center speaker".
 

Torroan

Estimable
Nov 7, 2014
3
0
4,510
0
I am gonna test what you said ssddx. By central speakers i actually meant that only the two Front speakers work, my mistake. The problem with the pc settings is that i've tried everything even changed the whole PC but still they did not operate.
 
Thread starter Similar threads Forum Replies Date
P Audio 2
S Audio 1
B Audio 0
druan08 Audio 2
S Audio 1
B Audio 5
M Audio 2
A Audio 2
M Audio 2
T Audio 4
W Audio 2
P Audio 8
B Audio 15
T Audio 10
S Audio 1
F Audio 2
sadab0 Audio 11
N Audio 1
M Audio 4
P Audio 1

ASK THE COMMUNITY