Static buzz when HDMI is plugged into laptop

Status
Not open for further replies.

Evan Amerio

Estimable
Jan 26, 2015
2
1
4,510
0
The problem I have today is that when I plug the HDMI (coming from a 1080p monitor) into my laptop my 2 monitors (JBL LSR305) start making static noise. Whenever the HDMI is plugged in it happens but when I disconnect it the noise goes away. I noticed that if I unplug the monitor with the hdmi still plugged in, the static stops, but when I plug the monitor back in the static starts again. I've looked at the problem online but can't figure out how to fix it. It's some sort of ground loop is what I came up with. Any help would be appreciated! Thanks.
 

Evan Amerio

Estimable
Jan 26, 2015
2
1
4,510
0


Plugged my monitor into an extension cord leading to a different outlet and it pretty much solved the problem completely. Thanks for that! I just need to figure out a better way to plug everything in without using an extension cord. I'm in the market for an audio interface which should get rid of the static, even with everything plugged into the same outlet.
 
Reactions: Noisyland
Status
Not open for further replies.
Thread starter Similar threads Forum Replies Date
M Audio 0
HerpTheDumbOne Audio 0
SpongeBobDid911 Audio 0
G Audio 0
Andrewplotplot Audio 0
D Audio 2
PierreGird Audio 1
GenericName987 Audio 1
LucyHearto Audio 1
A Audio 2
O Audio 1
djrakobeat Audio 2
I Audio 1
H Audio 2
Sithex Audio 1
A Audio 1
Y Audio 3
Punchofdeath Audio 1
R Audio 3
C Audio 1

ASK THE COMMUNITY