Question Stuck in BIOS Utility - EZ Mode | ASUS ROG Strix GL503VD

Apr 10, 2020
1
0
10
0
I haven’t been home for a few months, and I let my little brother keep my laptop for that time. When I came back I booted my laptop and was stuck in BIOS Utility - EZ Mode. I have searched many videos and read some forums posts, but nothing solved my problem. Some background information: I have check the internals to the best of my knowledge, and nothing seems out of place, damaged, or loosely plugged/attached. I am actually not aware if this laptop comes with an internal ssd stock, if it does then mine happens to be missing(probably as a result from my brother, though he says he never touched/lost anything). <- if I am missing the original ssd, is this a big problem?(I am not aware, or know too much about electronics) Because of this I took apart an old Acer Aspire 3 A315-21 series laptop of mine, removed the ssd, and switched it to be in my current laptop.(if possible let me know if this ASUS laptop does come with an ssd stock, I’ll have to find out what happened to it if it does come stock). Nothing changed with the situation. For both instances with and without the ssd this was the outcome; In my BIOS Utility - EZ Mode, any changes I attempt to save ultimately leads to a frozen screen. Upon restarting the laptop the “changes” to the setting seemed to have been saved. I have tried the disable boot secure, disabled fast boot, and enable csm method, but it does not work. Once I get to the part where I click “esc/escape” button it brings me to a screen that says : Please select boot device: Enter Setup. That is all, no other option but to just hit “enter”, bringing me back to BIOS Utility - EZ Mode.

ASUS ROG Strix GL503VD
BIOS Utility - EZ Mode info:
BIOS Version: 310
CPU: Intel(R) Core(TM) i7-77 00HQ CPU @ 2.80GHz
Total Memory: 18432 MB
Intel(R) HD Graphics 630 NVIDIA GeForce GTX
STORAGE
Controller 0, 1, 2 & 3
Device Type : Empty & Model Name: Empty
BOOT PRIORITY
Only option: Windows Boot Manager

I don’t know what information if helpful so I tried to give all I could gather, If anyone has a clue as to what happened and how I am able to resolve this, that would be very appreciated,

Thank you.
 
Thread starter Similar threads Forum Replies Date
C Laptop Tech Support 1
F Laptop Tech Support 5
SnackinMcCracken Laptop Tech Support 1
A Laptop Tech Support 1
J Laptop Tech Support 1
N Laptop Tech Support 2
N Laptop Tech Support 1
R Laptop Tech Support 1
P Laptop Tech Support 1
O Laptop Tech Support 1
B Laptop Tech Support 1
L Laptop Tech Support 1
P Laptop Tech Support 1
D Laptop Tech Support 2
G Laptop Tech Support 9
C Laptop Tech Support 1
L Laptop Tech Support 3
M Laptop Tech Support 2
R Laptop Tech Support 1
V Laptop Tech Support 7

ASK THE COMMUNITY