Tab S sometimes won't download files


Nov 8, 2016
Hi all, please help!

My Samsung Tab S can download most things: app store works fine, some PDFs do download & work fine .... but other PDFs - even different files from the same source website - simply don't do anything.
I can’t work out any difference why.
Problem occurs not only with pdf, but .aba & sometimes image files also.

The orange download indicator runs across the top of the screen (very quickly), but only a blank page comes up & nothing in the download folder.

It’s not the file: the exact same files download & open just fine on my S4 phone & other computers, so it is just this tablet device.
It’s not the browser: same problem experienced on 3 different browsers.
It’s not the viewer either: I’ve tried multiple viewers.

Some files of the same extension download fine ...some just won’t. It’s bizarre.
The same fexact same files that refuse to download on this tablet will open fine on this tablet if brought in from another device using email or usb. ??

The biggest trouble I am having is with files from my cloud accounting software (Xero) ... problems with most pdfs, aba files & some images files from this source ... but a few of the seemingly same do work ... argh!?! Mobile accounting is what I most need to use this tablet for.

The problem seems to have started around the end of May (it used to work fine), but not sure what is causing it.

Updates are up to date, & I have not fiddled with any settings.
There’s plenty of both internal & sd card storage space.
I’ve tried clearing the cache.
I’ve tried disabling & re-enabling download manager.
I have "McAfee all access" security software, which has not picked up any viruses etc.
Other than this issu, the tablet is functioning fine.

I am desperate to get this problem resolved as it makes my tablet pretty much useless for its intended purpose.

I am not alone, I have met other people experiencing the same mysterious problem with Samsung tablets ... & I've met others searching forums for anwers, but so far no seems to be able to help.

Any suggestions would be greatly appreciated,

With thanks,
Well, you can try doing a "Hard Reset", which will remove all things added to the device, including your personal stuff. However, since you don't have a frozen or non-working device, you can back up all your personal stuff (videos, photos, music, etc.) as well as a copy of your contacts to a computer or cloud account and then do the "Hard Reset". Once it is done, and the junk is all removed from the tablet, then you can put your own stuff back on it. I would, however, recommend saving a copy of all on the computer/cloud account, this way you can't lose it all if the device should fail, break, disappear, etc.

To "Hard Reset" the tablet...

1. Make sure that the tablet is actually powered off.

2. Remove your SD card, if there is one in the device.

3. Press the "Power" and the "Volume Up" buttons, together, until you see the start-up logo on the screen.

4. Once you can see the logo, release the buttons and allow the device to enter the "System Recovery Mode".

5. Next use "Volume Down" button to get to the "wipe data/factory reset" option When in recovery mode the "Volume Up" and "Volume Down" buttons are how to can navigate and highlight what option you need.

6. Once you have selected the "wipe data/factory reset", press the "Power" button to select that option.

7. On the following screen, repeatedly press the "Volume Down" button until the "Yes - delete all user data" option is what is selected.

8. Then press the "Power" button to hard reset the tablet.

9. If you took your SD card out in step 2, when the device is up and running again, reinsert the SD card.
If it shows as downloading really fast like that, the files source may be the problem. If a file is not created correctly, or not uploaded correctly, it can cause that. Which wouldn't be on your end, or the tablets.

Also, have you made sure the tablet (and your apps) are fully updated? And lastly, it is possible part of your problem is due to an app on the device that is causing problems. You might want to try running in "Safe Mode" and see if you can get the downloads to work that way. If they do, and you can view them, then you need to figure out what app is the culprit.

If none of that works, I would contact Samsung and see if there is a fix.

To get into "Safe Mode" please do the following.

1. First turn off the tablet.

2. Next press and hold "Power" until you see the manufacturers logo on the screen, then release the power button.

3. "Quickly" press "Volume Down" and hold it for few seconds until you see the message "Safe mode: ON" or something similar.

4. If you wanted disable it, simply repeat the steps above, and you should see "Safe Mode: OFF" rather than on.


Nov 8, 2016



Nov 8, 2016
Hi webworkings, Thankyou so much for your repsons, & sorry that it has taken me so long to answer back.

So yes, I think an app is the cilprit as the downloads will work fine in Safe Mode. Thank you.
I have unintalled all the apps that I have ever downloaded, that will let me uninstall them ... but some will not let me click the "disable" or "uninstall" buttons, & the problem has not gone away.

I have suspicions about an app called "OMACP" (icon is a green text bubble with a smilie face inside), I have no idead what this is/does or where it came from, but some others have implied that it might be malware, & it won't let me get rid of it.

So my researching led me to an app called "System App Remover" .... but this requires ROOT permissions (now I'm getting frightened...) this app recomends downloading yet another app from (now I'm really scared...) .... but the download from this site won't run for me .... appears to be due to my orginal problem with downloads that I am trying to fix ..... should I start my tablet in safe mode & try to download this 'oneclickroot' ..... or stay well away from it?!?

Any other suggestions? Thanks so much for your help!

Thread starter Similar threads Forum Replies Date
IvoryTerra Android Tablets 1
W Android Tablets 1
M Android Tablets 4
Leeigh Android Tablets 1
Z Android Tablets 3
P Android Tablets 1
G Android Tablets 3
S Android Tablets 1
A Android Tablets 1
K Android Tablets 2
J Android Tablets 1
C Android Tablets 1
M Android Tablets 1
J Android Tablets 1
C Android Tablets 2
V Android Tablets 1
D Android Tablets 3
D Android Tablets 1
J Android Tablets 1
P Android Tablets 1