Technics SL-L20 turntable tonearm stops moving during play

windows-xp

Estimable
Nov 25, 2015
8
0
4,510
0
Hello everyone,
I was feeling nostalgic and decided to play some of my old records, but there is a slight problem... during play, the tonearm stops moving! Although, using the cueing function works fine, it moves freely, as stated during play the tonearm stops moving. That being said, it isn't the records themselves, as I've tested many record.

Thanks.
 
Since that turntable has a linear tracking tonearm, (moves in a straight line) rather than a more conventional arm that pivots as the record plays, it is much more complex mechanically and had an electronic aspect too.
You would have to disassemble the TT until you could exam the arm mechanism. Could be easy - just need lubrication, might need a belt or rubber part, could be an electrical which would be tough and expensive.
 
Since that turntable has a linear tracking tonearm, (moves in a straight line) rather than a more conventional arm that pivots as the record plays, it is much more complex mechanically and had an electronic aspect too.
You would have to disassemble the TT until you could exam the arm mechanism. Could be easy - just need lubrication, might need a belt or rubber part, could be an electrical which would be tough and expensive.
 
Thread starter Similar threads Forum Replies Date
samyt485 Audio 2
L Audio 1
P Audio 2
O Audio 1
B Audio 4
N Audio 3
G Audio 0
T Audio 2
D Audio 2
T Audio 4
F Audio 5
B Audio 3
F Audio 4
G Audio 1
J Audio 1
L Audio 2
V Audio 2
G Audio 4
L Audio 1
M Audio 3

ASK THE COMMUNITY