This feedback is destroying me.....

Kangaroo Hop

Honorable
Mar 4, 2013
3
0
10,510
0
Hello friends,

So recently I bought a new sennhiser game zero headset, now the sound quality is great , and so it should be considering the price of the headset, however there is one thing bugging me and that is that the headset produces quiet feedback, it could probably be best described as white noise and it makes it so my voice isn't as clear as it should be. Even my previous 80$ headset didn't produce this noise. When I listen to playbacks of my headset the noise is extremely obvious. For your information the my onboard sound is a Realtek ALC887, could this be the cause of my problem? Any help is appreciated, thank you.
 
with sound cards and feed back..make sure your running the newest audio driver. also if your unit is usb or wireless make sure there no power wires or speakers or wifi units near you that can be causing feedback. also try your units on another pc if the hum is there you may have gotten a bad unit.
 

Kangaroo Hop

Honorable
Mar 4, 2013
3
0
10,510
0


Hi Smorizio, I connected my headset (wired) to my laptop then listened to my voice and it was crystal clear, no static white noise to be heard, then i connected it back to my pc and its still there?
 
Thread starter Similar threads Forum Replies Date
860TecK Audio 0
B Audio 3
B Audio 1
S Audio 2
D Audio 1
Shaun98 Audio 1
M Audio 2
T Audio 1
S Audio 1
S Audio 1
E Audio 2
Froggman Audio 4
B Audio 2
Z Audio 1
C Audio 1
H Audio 1
A Audio 1
T Audio 2
L Audio 1
G Audio 4

ASK THE COMMUNITY