Toshiba Qosmio wont boot up anymore

Feb 12, 2018
3
0
10
0
Hello,

My Toshiba Qosmio X505-Q870 won't boot up any longer. The power light and LED will come on, as well as the charging LED indicator when plugged in. The fans also come on, but instead of slowing down after the initial boot, they continue droning at a higher constant speed. No screen, no backlit keyboard, haven't noticed the hard drive indicator flickering either.

I just put a new SSD in about a month ago which dramatically improved performance. I would still get occasional BSOD's after the SSD install, although not nearly at the rate as before. Everything has been running smoothly for the most part prior to this.

Is my motherboard toast? And if so, the real question is, where can I find one?? I've been doing a little searching with this assumption in mind, but have had little luck in finding a match. I'm a little suprised that they seem to be non-existent, even with the age of the PC. I'd really like to keep it going if at all possible, as it still worked great and a new PC purchase is not really an option at this time. Thoughts?
 
Then it is actually booting up. But the display isn't.

Try this...

1. Turn the laptop off (not sleep or hibernate but off).
2. Connect an external monitor to the laptop.
3. Turn on the external monitor.
4. Turn on the laptop.

NOTE: You may have to press an "external monitor" button. Could be the f4 button or a button with two monitors on it, for the external monitor to work.

If you can see fine on the external monitor, then your attached display, or the ribbon cable that connects it, are your problem.

If you can't see on the external monitor at all, or the problem occurs on the external monitor as well, then it is probably the graphics card/GPU that is the problem, which may require the motherboard be replaced.
 
Feb 12, 2018
3
0
10
0

I have had it plugged into an external monitor to no avail, as the external display does not find a signal, but I will try it the way you listed.

This PC has long had issues with the built in display not turning on until I tweak it or close/open the lid, but it always works when plugged into an external monitor. So I am used to having display issues, but this time its acting differently -- almost brain dead.

I will let you know what I find once I am back home.
 
Feb 12, 2018
3
0
10
0
I tried what you said with no luck.

Is there a way to verify what the issue is, whether it is the gpu, or the entire motherboard needs replaced?

 
Well that would require you have the board tested. However, in many cases, the GPU may not be replaceable on its own anyway. Meaning it would require the motherboard be. If you can test it at home yourself, great. If not, I would try a local tech.
 
Thread starter Similar threads Forum Replies Date
junior31210 Laptop Tech Support 1
J Laptop Tech Support 1
Q Laptop Tech Support 1
K Laptop Tech Support 3
Cloudy1 Laptop Tech Support 2
Upendra09 Laptop Tech Support 4
K Laptop Tech Support 1
S Laptop Tech Support 3
L Laptop Tech Support 1
A Laptop Tech Support 1
D Laptop Tech Support 5
A Laptop Tech Support 1
L Laptop Tech Support 1
C Laptop Tech Support 5
L Laptop Tech Support 8
A Laptop Tech Support 1
L Laptop Tech Support 2
J Laptop Tech Support 3
S Laptop Tech Support 1
N Laptop Tech Support 4

ASK THE COMMUNITY