Toshiba Satellite C650D Black screen after Toshiba logo

Mitchell_5

Estimable
Sep 19, 2015
2
0
4,510
0
Hi,
My laptop cannot tell me any post after the Toshiba logo just black screen. Cannot get into the bios or anything... These are the things I have tried:
Taken hard drive out,
Taken ram out and only tried one..
Taken Battery Cmos battery out for a few minutes..
Had a look at the motherboard and fan is not even working when I turn it on..
I have taken the cpu and put it back in..
Defiantly Sounds like the motherboard problem but want to know if its just a chip that needs to be replaced and soldered.. If anyone has any ideas that will be awesome.

Thanks
 
Hi,

If the laptop still shows the Toshiba logo as you mentioned before it goes into a black screen there could still be some possibility that there's life on the motherboard. Try hooking an external monitor on your laptop and see if you'll get any display after the Toshiba logo. If it doesn't a possible culprit is the video card of your laptop might had been damaged already and there could be a lot of things in your motherboard board that could have gone bad and replacement is the only way around it.
 

Mitchell_5

Estimable
Sep 19, 2015
2
0
4,510
0
ok cheers i'll give that ago.. What I have notice when I have taken the ram out I started the laptop and Im getting a post beep.. so at lest something is responding... Let me know if you have any other ideas. thanks
 
Thread starter Similar threads Forum Replies Date
C Laptop Tech Support 3
Eligijus Laptop Tech Support 1
Eligijus Laptop Tech Support 1
wolfluvr Laptop Tech Support 1
J Laptop Tech Support 3
A Laptop Tech Support 1
Bluemoon1502 Laptop Tech Support 1
G Laptop Tech Support 3
O Laptop Tech Support 5
D Laptop Tech Support 1
XVII Laptop Tech Support 0
R Laptop Tech Support 1
KnottyCord Laptop Tech Support 2
ahindi Laptop Tech Support 0
Debs70 Laptop Tech Support 3
R Laptop Tech Support 0
Blitzkreig Laptop Tech Support 1
Adele K Laptop Tech Support 1
CookieSecretz Laptop Tech Support 1
Yishai Laptop Tech Support 0

ASK THE COMMUNITY