toshiba Satellite P55t-A5116 Charging circuit works, but when i goto power on, the fan spins a few seconds and the white power

theestever1

Distinguished
May 24, 2009
1
0
18,510
0
toshiba Satellite P55t-A5116 Core i5: Charging circuit works, but when i goto power on, the fan spins a few seconds and the white power lite blinks then goes out and no boot.
 
Try the following and see if it will turn on...

1. First make sure the device has been charged.
2. Unplug your charger cord.
3. Remove the battery.
4. Press and hold the "Power" button for 30 seconds.
5. Now plug back in the power/charger cord.
6. Now put the battery back in.

If this doesn't help, then test the power cord to see if it is good. Either try your cord in another device, or try another devices cord in your laptop.

Should that not be the problem, then check the battery to see if it needs replacing.

 
Thread starter Similar threads Forum Replies Date
M Laptop Tech Support 1
P Laptop Tech Support 5
V Laptop Tech Support 2
N Laptop Tech Support 0
J Laptop Tech Support 8
N Laptop Tech Support 4
C Laptop Tech Support 1
M Laptop Tech Support 1
T Laptop Tech Support 0
Comp@U Laptop Tech Support 2
skoochie Laptop Tech Support 5
Mirandarenee Laptop Tech Support 6
T Laptop Tech Support 4
M Laptop Tech Support 0
Stevet1 Laptop Tech Support 6
C Laptop Tech Support 0
bd01ng Laptop Tech Support 3
shujinko45fox Laptop Tech Support 1
Ioannis1981 Laptop Tech Support 8
V Laptop Tech Support 1

ASK THE COMMUNITY

TRENDING THREADS