Upgraded Ram, now laptop screen is black when intel HD 4600 is enabled.

Feb 5, 2019
1
0
10
0
Hi there.

So I've a complex problem with my Asus N56JN laptop. There's a lot I've tried and a lot I've figured out to give some clues. If anyone can help if really appreciate it.

The laptop has been performing perfectly fine. But.. after a Ram upgrade, my screen started going black after the Windows logo during boot. Windows sounds were still present.
I narrowed this down to the Intel HD 4600 driver. With it disabled, I can boot up using the basic display adapter, sacrificing any kind of gaming. Whenever I attempt to install the HD 4600 drivers from Intel, the screen goes black during installation with windows sounds still present. I can hook the laptop up through HDMI and use the keyboard shortcut for extended display to get a display on my TV. Here's where it gets confusing, the Intel driver functions perfectly through the TV, so the chip definitely isn't dead! And using the TV, I can install the Geforce drivers, and that card also functions perfectly through the TV. But I can only use the Nvidea control panel when connected through HDMI. If I disable Intel HD graphics after Geforce is installed, the system reverts to the basic display adapter and I can use the laptop screen, but launching nvidea setting brings up the error "You are not using a display connected to a Nvidea GPU
My geforce 840m drivers require an Intel driver to be installed first, so I cannot bypas the Intel HD graphics installation.
(Yes, the Ram I installed is reading correctly as 8GB. And I have tried reverting to the old chip to no avail)

These are the things I have tried.

I tried all kinds of system restore/repair to no avail. Hesitantly I reinstalled windows 10. Clean install - Same problem.
I decided to format the entire drive including system reserved and then reinstall windows 10 - same problem.
I tried installing Windows 7 - same problem.
I installed Ubuntu. Drivers seemed to work perfectly, so laptop screen and chips cannot be dead or defective.
I would blame poor compatability, however, these chips were working a week ago on Windows, and now are only functioning properly on Linux.

I've tried pretty much everything except for opening up the thing, but I'd like to leave that as a last resort. My guess is that if the laptop display wasn't connected to the motherboard properly (or was defective), I wouldn't even get a display in safe mode right?

Any suggestions would be greatly appreciated.
 
Thread starter Similar threads Forum Replies Date
H Laptop Tech Support 2
V Laptop Tech Support 1
L Laptop Tech Support 1
S Laptop Tech Support 0
D Laptop Tech Support 1
R Laptop Tech Support 0
R Laptop Tech Support 0
A Laptop Tech Support 3
P Laptop Tech Support 1
K Laptop Tech Support 1
L Laptop Tech Support 3
GambitGamer Laptop Tech Support 0
T Laptop Tech Support 4
C Laptop Tech Support 4
J Laptop Tech Support 1
D Laptop Tech Support 3
L Laptop Tech Support 3
J Laptop Tech Support 7
S Laptop Tech Support 1
C Laptop Tech Support 2

Similar threads


ASK THE COMMUNITY

TRENDING THREADS