Weird Display Problem

Raktavija

Estimable
Apr 14, 2015
5
0
4,510
0
I have a Samsung NP300E5C that is three years old.

The screen will stay black when I power on the computer. All I can hear is the fan. The hard-drive light does not turn, maybe it flickers once.

I've checked all connections and they're all in place.

I reset the CMOS and BIOS by removing the lithium battery on the motherboard.

I checked the RAM to be sure that it is seated correctly. This is where it gets weird.

When I move the RAM (only one 4GB stick), to the open slot, and then power on the laptop, the display works. Once I shut down the computer and turn it on, the display is black, once again. Rinse, repeat.

I've also tested this with RAM that I know is working fine.

What's going on? Anyone have an idea? I'm stumped. A motherboard replacement is expensive but it seems I may have no alternative.
 

Raktavija

Estimable
Apr 14, 2015
5
0
4,510
0


Yes, I have tried this. Unfortunately, it did not work.
 

Im Spartacus

Estimable
Mar 25, 2015
339
0
5,210
78
Just a thought you say you removed the CMOS battery and replaced it back did you try to replace it with a new one a failed or failing battery can cause all sorts of issues with ram, messing up your bios even effecting booting up problems? They don't cost a fortune and worth a try.
Get a good one from Maplin not one of those pound shop jobs 8 or 10 in a packet.
 

Raktavija

Estimable
Apr 14, 2015
5
0
4,510
0


I will try this ASAP!
 

BadAsAl

Distinguished
So when you move the RAM from the original slot to the other slot, it boots, but when you shut down and restart, it goes black screen again? If you then move the RAM back to the original slot, does it boot at first, but then go back to black screen after shut down and restart?

I have seen very strange behavior with graphics caused by the CPU as well. I was lucky I had another laptop with the same processor and was able to swap them to confirm that was the problem before I ordered one. CPU will be cheaper than motherboard usually and might be worth a try.
 

Raktavija

Estimable
Apr 14, 2015
5
0
4,510
0


Yes, that is exactly what happens. When I remove it from one slot and seat it in the other, it boots. When I shut it down, and boot up again, there is just a black screen. This happens for both slots.
 
Thread starter Similar threads Forum Replies Date
specuuu Laptop Tech Support 5
M Laptop Tech Support 4
Poxeh Laptop Tech Support 5
sm23 Laptop Tech Support 9
P Laptop Tech Support 6
Mythical22 Laptop Tech Support 3
J Laptop Tech Support 1
D Laptop Tech Support 2
A Laptop Tech Support 1
P Laptop Tech Support 1
bubesz94 Laptop Tech Support 1
ssam039 Laptop Tech Support 2
_dawn_chorus_ Laptop Tech Support 2
Megzari Nassim Laptop Tech Support 1
P Laptop Tech Support 1
cavalierz2 Laptop Tech Support 7
K Laptop Tech Support 1
A Laptop Tech Support 2
R Laptop Tech Support 1
B Laptop Tech Support 2

ASK THE COMMUNITY