Question Weird problem with charging

szepszu

Prominent
Jun 30, 2018
2
0
510
0
Hey guys!

First of all, I have a ASUS TUF Fx504 Notebook and I recently upgraded the ram in it from 8GB to 16GB.

Everything went fine, until I wanted to plug the charger in. When I did, my second monitor lost signal, and the built-in display turned black. It didn't shut off, it just showed black. If I pulled the charger out the screen remained black, nothing changed.
I shut down the notebook and tried to boot up again. I get the post screen, I see the ASUS logo, and after that nothing but complete darkness. As before, the display was working, it was just showing black. And, what was weird to me, that the power indicator and the airplone mode indicator were lit up.

I tried to boot with the charger not plugged in, and it worked. At least I thought so. It worked in the beginning but if I try it now the screen turns black after approx. 10-15 seconds after logging into my account.

What is the weirdest for me is if I boot into safe mode everything works fine. I can even charge my laptop without any problems.

Of course, I've tried without the new RAM module, nothing changed.

I really hope one of you guys can help me, I'm hopeless.

Cheers!
 
Thread starter Similar threads Forum Replies Date
C Laptop Tech Support 1
M Laptop Tech Support 4
D Laptop Tech Support 2
Z Laptop Tech Support 1
T Laptop Tech Support 3
L Laptop Tech Support 1
D Laptop Tech Support 1
T Laptop Tech Support 6
J Laptop Tech Support 3
R Laptop Tech Support 2
O Laptop Tech Support 1
K Laptop Tech Support 1
I Laptop Tech Support 4
L Laptop Tech Support 1
D Laptop Tech Support 2
M Laptop Tech Support 1
M Laptop Tech Support 1
A Laptop Tech Support 1
N Laptop Tech Support 1
T Laptop Tech Support 2

ASK THE COMMUNITY