When I connect my laptop to TV via HDMI cable, I have sound on laptop but not through TV

Page 2 - Seeking answers? Join the Tom's Guide community: where nearly two million members share solutions and discuss the latest tech.
Status
Not open for further replies.

orlbuckeye

Distinguished
May 1, 2009
614
0
19,210
72
HDMI replace the old AUdio video cables because HDMI passes both video and audio. On my setup when my laptop is connect to the TV with a HDMI cable the ATI HDMI output appears in \\control Panel\Sound. If i remove the HDMI it disappears.

Your TV may not be fully compatible. Remember if compatible the HDMI out WILL appear in control panel/sound/ playbackl

http://h10025.www1.hp.com/ewfrf/wc/document?docname=c01409647&cc=us&dlc=en&lc=en
 

parispinup

Estimable
Jul 8, 2014
1
0
4,510
0


Just wanted to thank you for this. It was the ONLY thing that worked for me! Annoying, yes, but it got the job done.
 

noturaveragechick

Estimable
Sep 23, 2014
1
0
4,510
0


So helpful! Thnx!!! Netflix is nothing without TV sound!
 

orlbuckeye

Distinguished
May 1, 2009
614
0
19,210
72


You have to change your sound default under sound. My laptop has my realtek sound card as the default sound card when it's not connected to TV. Then when its connected to another device My graphics card pops icon (which is ATI) up under sound and i make that the default. HDMI allows video and sound audio devices and the Graphics card controls that with HDMI.
 

Eric111

Estimable
Jan 2, 2015
1
0
4,510
0


My HDMI laptop into TV sound was working fine one day and gone the next. Not happy! After spending hours looking at all the info about this issue I finally figured out a way to fix it. I wasn't able to see the option of choosing 'hdmi output' in the sound options (it wasn't hidden) that is so often said to fix the problem. I phoned up Acer (my laptop is Acer) and they were hopeless. I knew more about the problem than they did and they did nothing to help.

In the end what I did was this:
Went to Google and searched for REALTEK HDMI AUDIO DRIVER
Opened the Realtek website
Accepted the terms under the heading High Defintion Audio Codecs
Clicked on the Windows 7 link in US1.
It downloaded in about 7 minutes then I ran the program.
Restarted the laptop.

Everything was back up and running.

Hopefully that helps someone that has tried everything else like I did.
Eric

 

HannahRoseLouise

Estimable
Jan 23, 2015
1
0
4,510
0
I've literally tried everything you have all said and it still isn't working! I've got a Dell Laptop and my tele was bought at christmas so is new but its a Blaupunkt. Please Help, all i want to do is watch a film with my daughter.
 

tdawn

Estimable
Jan 25, 2015
2
0
4,510
0
Right click on the volume/speak in the lower right hand corner. click playback tab, right click on the speaker or what every shows up in that box. click show disabled devices then your disabled devices will apear. Right click on the tv monitor, click enable. It just worked for me.
 

tdawn

Estimable
Jan 25, 2015
2
0
4,510
0


Right click on the volume/speak in the lower right hand corner. click playback tab, right click on the speaker or what every shows up in that box. click show disabled devices then your disabled devices will apear. Right click on the tv monitor, click enable. It just worked for me.
 

Daly12323

Estimable
Jan 29, 2015
1
0
4,510
0
Think it depends on your graphics card. It controls the audio through hdmi.
Im running on an Intel HD Graphics 4000 card and I've had this problem for months. Finally solved it!!

Solution: reinstall Intel Graphics Driver for your version of windows. Make sure your graphics card is on the list of supported graphics cards.
Im running Windows 8.1.
This link is for windows 7/8/8.1 64bit systems
https://downloadcenter.intel.com/Detail_Desc.aspx?DwnldID=24329&lang=eng

If you are running on a different graphics card just reinstall the latest graphics drivers from manufacturers website or install a graphics control centre which is associated with your graphics card


 

Amj Parkar

Estimable
Feb 22, 2015
1
0
4,510
0


I think I might have solved this motherfffffff. Basically you need to go onto the Intel website and download a utility (under the downloads and drivers tab) that will check for the latest drivers. Download that, install, let it do its work and I reckon it will tell you that you need an update. Download the update, install it, restart your computer if prompted to and I think your problem will be solved. Please let me know if it works!
 

Devrim

Estimable
Mar 20, 2015
1
0
4,510
0


 

Darren Attard

Estimable
Apr 28, 2015
1
0
4,510
0
Hi guys

To resolve the problem of HDMI.
When you connect the HDMI cable into your Laptop, the sound is heard from the laptop rather than the TV.

The problem can be resolved by following these few steps:
1. Press the Start Button
2. Control Panel
3. Once you are in the Control Panel, click Sound.
4. In the Playback Tab, you should find 2 sources - TV and Speakers
5. Right Click the TV and click enable and the Sound is changed to TV (Changed from Laptop to TV)

If the TV is missing:
- In the Playback tab, right click and press Show Disabled Devices to enable hdmi.
- And than complete the process which I previously stated earlier.


Another way to resolve the problem is to connect the HDMI before turn your Laptop on.

I hope that this will solve the problem guys :)

 

AML1102

Estimable
May 10, 2015
1
0
4,510
0



Finally! I realize this is an older post, but this worked and was so simple. I've already spent a couple hours on the problem, but at least it was a simple solution.
Thanks!
 

Stan06wm

Estimable
Jun 2, 2015
1
0
4,510
0


Thank you Thank you Thank you...This worked like a charm. ....been trying tons of other potential solutions for months....Fyi....I have a Samsung TV
 

curiositykimmy

Estimable
Jun 5, 2015
1
0
4,510
0
Thank you zerrryu ! worked like a charm! just wish I would have seen your solution at the beginning of the posts. I am still so thankful. Here is the a solution to try. Right click speaker icon, go to playback devices, right click the speaker option ( T.V option is probably missing) than hit " show disabled devices", enable HDMI through T.V. than your done.
 

bigdaddybrant

Estimable
Aug 5, 2015
1
0
4,510
0
I have asus x553m laptop. I also was having no sound through hdmi cable. I could disable speaker on laptop and would get sound through hdmi. I was not happy with this solution. After more digging around I found the solution for me. In windows media player under more options after right clicking on screen navigate to the "DEVICES" tab. Highlight speakers then properties. Change "select the audio device" to default audio device not laptop speaker. Apply this and sound should be fine. works for me.
 

Chris Clement

Estimable
Aug 15, 2015
1
0
4,510
0



I did this and I still can't get any sound to my tv from my laptop using hdmi cabvle
 

inatacho

Estimable
Aug 16, 2015
1
0
4,510
0


Hi. I'm not tech at all. You must connect the HDMI cable to your tv BEFORE you start/open file of the movie. If you start the movie and then connect the HDMI you will have no audio.
Cheers!
 

Shaker5585

Estimable
Aug 18, 2015
1
0
4,510
0
its not the cable. i have been able to use my laptop with my tv for over a year. since i got the tv. with no issues. there's gotta be another reason why now all of a sudden I can't get sound to my tv via hdmi output even though everything on my laptop is set for this to work. maybe an update to some software is causing the issue? i dunno yet.
 
Status
Not open for further replies.
Thread starter Similar threads Forum Replies Date
A Laptop Tech Support 2
P Laptop Tech Support 1
K Laptop Tech Support 2
A Laptop Tech Support 5
B Laptop Tech Support 1
A Laptop Tech Support 1
F Laptop Tech Support 6
S Laptop Tech Support 1
J Laptop Tech Support 1
E Laptop Tech Support 6
T Laptop Tech Support 1
B Laptop Tech Support 1
Ordan Laptop Tech Support 3
S Laptop Tech Support 3
L Laptop Tech Support 1
L Laptop Tech Support 1
B Laptop Tech Support 3
J Laptop Tech Support 3
S Laptop Tech Support 4
N Laptop Tech Support 3

Similar threads


ASK THE COMMUNITY

TRENDING THREADS