When I entered BIOS and gone to the boot tab no boot mode such as UEFI and Legacy doesn't appear

Aug 29, 2018
When I boot my Acer Spin 1(SP111-31) To BIOS and gone to boot tab no boot mode (such as UEFI and Legacy) doesn't appears which is the biggest problem of "No Bootable Device"

Looking forward for reply

Phillip Corcoran

Laptops typically have only a few user-changeable settings in the BIOS, only retail motherboards have a full range of BIOS settings. The BIOS is very limited on laptops to stop you messing it up and expecting the manufacturer to fix it.

"No Bootable Device" appearing on screen when you turn your laptop on has nothing to do with UEFI/Legacy selection.

It means that you either need to reinstall Windows, or the HDD may have failed. There may be other causes for the error which I'm not aware of.


Sep 17, 2016
Acer appears to have begun phasing out Legacy BIOS mode a couple years ago. No Intel supplied firmware will include it any more by 2020.

So only GPT/UEFI compatible USB drive will boot, and only distros that have paid for a trusted secure boot certificate will be able to be installed.
Thread starter Similar threads Forum Replies Date
A Laptop Tech Support 5
S Laptop Tech Support 4
abajan Laptop Tech Support 6
G Laptop Tech Support 1
K Laptop Tech Support 1
bubesz94 Laptop Tech Support 1
H Laptop Tech Support 1
X Laptop Tech Support 1
C Laptop Tech Support 1
G Laptop Tech Support 1
S Laptop Tech Support 1
A Laptop Tech Support 1
C Laptop Tech Support 2
M Laptop Tech Support 1
F Laptop Tech Support 1
F Laptop Tech Support 4
S Laptop Tech Support 1
D Laptop Tech Support 1
M Laptop Tech Support 2
2 Laptop Tech Support 4
Similar threads
Question Asus T101-HA does not enter sleep mode by command
Question External keyboard - Enter not working
Question After Entering Proxy Address and Port, Clicking "OK" Does Nothing
Question Thinkpad T460s won't stay powered on after showing, "Press Enter to interrupt normal startup operation.."
Question Aspire E 15. Windows 10 Cannot enter PIN .. unresponsive to keyboard entry
Question Why does my Enter and Backspace act weirdly?
Solved! Entering bios during PXE-MOF error.
Solved! My laptop won't boot or enter bios
Laptop keyboard presses enter+"L" when I press "L" key and "-." when I press the "." key-.
Solved! Im pressing the letter g and it types g and v backspace or enter doesnt work
My Windows 10 ASUA laptop allows me to enter the network key but does not connect to it
entering bios with external monitor, Tosiba Satellite C50-b 158
when i turn on my asus sonicmaster laptop it goes right to enter password and i dont remember it how do i get pass that and ge
Solved! My dell laptop shows password wrong even after entering right password..few days ago I opened it with the same password ...but
Solved! I have an Asus Laptop, when i entered Bios it reads the gpu as 930mx and then when i boot into Windows it reads the gpu as nvi
Question Laptop does not come on after it enters sleep or hibernation.
Good mornig sir I am trying to enter a password in my Samsung np-nc108 I can't see even CMOS in side i have done almost everyt
Enter key in the num pad is not working in video games.
I have been trying to reset lp top but when I go thru the possess I am still required to enter in password hat can I do. Whil
Acer V5 cannot enter legacy bios to edit