Windows is responding slowly

Aiden2k13

Honorable
Dec 19, 2013
79
0
10,590
2
Hello, need a little help. Windows seems a bit slow. Any application such as any game takes some time to launch ( all legit games ) since some days. A bit delay in response.
Plenty of Space left in all partitions including Windows Drive ( SSD , which is only dedicated to the Windows ). Total 13 TB of Storage .
I am on Legit Win 10 x64. Using Kaspersky Internet Security 2016 ( Legit ).
Any thing I can do to fix it ? Any software or something ?

Thanks in advance.
 

Ralston18

Splendid
Moderator
Run "perfmon /res" via the Search the web and Windows" bar (just type without quotes) and look at the various tabs to see what is running, how much CPU time is being used, how much memory is being taken by the services and applications that are running.

You can also use msconfig to find out what is being started at boot time.

Look at the Event Viewer logs and see if any errors are cropping up during launch.



 

Aiden2k13

Honorable
Dec 19, 2013
79
0
10,590
2


CPU Usage
That is the CPU usage in the task bar when I was playing CS GO.
 

Ralston18

Splendid
Moderator
Good but I do not know what "normal" CPU usage is for your system.

Are you using virtual memory - if so what drive is that on?

I do see 104 processes running - take a look at the processes and see if any of them, other than CS GO related, are grabbing CPU time or otherwise hogging some resource needed by Windows.

Also there is some little bit of activity taking place on Disk 2 - is that a backup, AV scan.....

Boot up but do not immediately run any games or apps. Then start loading up games and apps one at a time and slowly. Do that while watching the monitor. See if any one program causes a change and a resulting performance drop.

Another thing I would try is, just for testing, is to disconnect drives 2 and 3. See if all of those partitions are causing some issue.

Overall, just work via a matter of elimination to determine when the expected performance returns or drops again.
 

Aiden2k13

Honorable
Dec 19, 2013
79
0
10,590
2


Disk 2 is my E , J and K drives where I store my movies and stuffs. Nothing else and no AV scan was going on.
Its weird that I just checked now and it still shows 2 % activity and then returns back to 0 % and then again 2 % and then 0 %. :/
 

Ralston18

Splendid
Moderator
Interesting. Thanks.

Good time to start loading up apps and games to see when and if the performance falters and what process brought that about.

Could be some app "phoning home" or some update trying to execute.

Then, if appropriate, stop that process and see if performance returns.

The more you work at it and watch things the more you will learn with respect to your system. At some point you will be able to say "that is it".
 
Thread starter Similar threads Forum Replies Date
L Apps General Discussion 0
T Apps General Discussion 0
N Apps General Discussion 1
I Apps General Discussion 5
omar muzzammil Apps General Discussion 2
David___Only Apps General Discussion 0
KloneCSGO Apps General Discussion 2
W Apps General Discussion 1
N Apps General Discussion 2
S Apps General Discussion 4
K Apps General Discussion 1
P Apps General Discussion 1
R Apps General Discussion 4
M Apps General Discussion 1
kikani.kautik Apps General Discussion 2
Z Apps General Discussion 2
S Apps General Discussion 1
D Apps General Discussion 1
B Apps General Discussion 2
A Apps General Discussion 1

ASK THE COMMUNITY