Yamaha A-S2100 amp won't work after power cut

Sep 4, 2018
2
0
10
Best answers
0
The dimmed Standby/On light blinks rapidly. The troubleshooting section didn't help. Would ask at the manufacturer's site but didn't find any.
 
Oct 8, 2018
3
0
10
Best answers
0
Hi, I have the same amp with exact the same problem☹. Did you find an solution for this problem? Regards SvenO (from Norway)
 
Aug 27, 2008
14,019
30
103,090
Best answers
7,512
If you unplug it from the AC outlet and plug it back in that might reset the amp. If that doesn't help you can open the unit and see if their are any fuses that might have blown. It's possible that the unit was damaged when power came back on and is now in protection.
You are going to have to contact Yamaha support to get it repaired. In warranty I hope. I would guess that Yamaha should have a website in every country it is sold.
https://usa.yamaha.com/support/index.html
 
Sep 4, 2018
2
0
10
Best answers
0
Page 30 of the Service Manual:
Turn the Balance knob, Treble knob and Bass knob clockwise fully and while pressing down the Audio Mute switch, set the Standby/On switch to the On position and keep pressing down the Audio Mute for 3 seconds or longer. The Standby/On indicator lights up.
 
Oct 8, 2018
3
0
10
Best answers
0
My amp was today repaired, the power supply card was the problem. Yamaha Norway did consider this as a warranty repair
 
Thread starter Similar threads Forum Replies Date
D Audio 0
D Audio 4
Tofoss Audio 2
Ausbeancounter Audio 3
M Audio 1
N Audio 0
Quitkclee Audio 1
S Audio 1
R Audio 3
M Audio 2
F Audio 2
B Audio 0
A Audio 0
C Audio 1
A Audio 2
B Audio 4
A Audio 13
C Audio 1
C Audio 0
D Audio 5

Similar threads


ASK THE COMMUNITY

TRENDING THREADS