Acer Aspire Laptop crashed and will not restart after hard boot

sheighton

Honorable
Sep 1, 2013
3
0
10,510
0
I have had a few minor problems in the past with the laptop, I mean who doesn't? But this time its a bit different. For anyone who is familiar with the game "Sins of a Solar Empire" it is a fairly resource heavy game. Now considering my laptop only is a Core i5 (quad) with 4GB of RAM and Radeon 6550M graphics, I usually keep the settings on the lower side, don't run too much in the background, and rarely (if ever) zoom in on larger space battles...and that leads me into how I got the machine to hard lock on me; zoom in, video goes black (aka screen shuts off), music continues for a bit, then cuts out. Ctrl+Alt+Del did nothing, so I press and hold the power button to shut it off. Press it again to start it back up and all the machine does is blink the LED on the front and the one in the power button 5 times at once at one second intervals.

I tried doing an electrostatic discharge (remove the power cord, remove the battery, and depress and hold the power button for at least 30 seconds) and it still doesn't work. As it is a laptop and they do tend to run a bit hotter than desktops, you might now be wondering if it overheated; it was running no hotter than usual and I use a lap stand for it that provides a little more room for air to circulate. I have had to hard boot several times in the past, but have never had an issue like this...

It won't even power on, let alone start a boot-up sequence or boot to the bios or beyond that to Windows.

I run Windows 7, everything is up to date, and the machine is clear of all viruses, spyware, and malware (I do run firewalls, and regularly scan it using Spyware S&D, Malwarebytes, AVG, and I use CCleaner for file cleaning, registry repair, and defrag).

Any ideas? Open her up and pull the CMOS chip? Or just take it in somewhere for repair...?

*** UPDATE: After plugging the power cable back in and reinstalling the battery, I have let it charge for 5 hours. No change. Bad battery...? Also, the laptop will not do anything (power button doesn't even flash) when no battery is installed... ***
 
Thread starter Similar threads Forum Replies Date
J Laptop Tech Support 0
dietherdeyv Laptop Tech Support 0
Kjlaptop Laptop Tech Support 0
M Laptop Tech Support 0
ruslruslrusl1 Laptop Tech Support 3
F Laptop Tech Support 1
Y Laptop Tech Support 10
G Laptop Tech Support 1
G Laptop Tech Support 6
C Laptop Tech Support 1
M Laptop Tech Support 1
r090t9 Laptop Tech Support 5
Acer aspire e 15 Laptop Tech Support 2
HolyDog Laptop Tech Support 5
R Laptop Tech Support 4
Kirstie_P Laptop Tech Support 3
K Laptop Tech Support 1
A Laptop Tech Support 1
D Laptop Tech Support 4
S Laptop Tech Support 1

ASK THE COMMUNITY