Acer aspire no display and power led blinking.

asheeshkumar636

Prominent
Feb 2, 2018
4
0
510
0
Hello,
I have an Aspire E5-573-32JT with Windows 10 Pro. I bought it last year, it was working fine till yesterday. Yesterday I spelt few drops of water on the upper side of touchpad. I quickly soaked as much as I can from a towel. But after 20 seconds, laptop went off. I quickly open the laptop and saw that there was a few drops of water under the trackpad, a drop was also on space key but no water on motherboard. I cleared all the water and turn on the laptop again. It turned on but started automatic repair then showed me advanced repair option then shut down after a few seconds. It happened three times.
Next day I put all the parts in sunlight to remove any moisture. I turn it on and it worked fine. After around 1 hour, it shut down again without any warning. I turn it on again and it worked fine again. But after a few hours it again shut down. Laptop was not heating at all and battery was around 70%.
When I tried to turn it on again, power led blinks 5times and nothing happened in the display. Although I can see that pixels were turning on in the display. I removed battery and press power button for 20 seconds then turn it on using adapter but same thing. I reseated RAM and unplugged touchpad and all other unnecessary usb cables from motherboard and tried to turn it on, but power led blinks for 3 or 5 times then goes solid for 30 seconds and then shutdown. I can see that pixels of display turns on but nothing happening on the display, it is all black, not the acer logo. Now when I am trying to turn it on, power led goes solid without blinking, fan and HDD rotates, pixels turn on in the display and everything shuts down after exact 30 seconds.
Any help will be appreciated.
 

asheeshkumar636

Prominent
Feb 2, 2018
4
0
510
0
MERGED QUESTION
Question from asheeshkumar636 : "Acer aspire no display and power led blinking"

Hello,
I have an Aspire E5-573-32JT with Windows 10 Pro. I bought it last year, it was working fine till yesterday. Yesterday I spelt few drops of water on the upper side of touchpad. I quickly soaked as much as I can from a towel. But after 20 seconds, laptop went off. I quickly open the laptop and saw that there was a few drops of water under the trackpad, a drop was also on space key but no water on motherboard. I cleared all the water and turn on the laptop again. It turned on but started automatic repair then showed me advanced repair option then shut down after a few seconds. It happened three times.
Next day I put all the parts in sunlight to remove any moisture. I turn it on and it worked fine. After around 1 hour, it shut down again without any warning. I turn it on again and it worked fine again. But after a few hours it again shut down. Laptop was not heating at all and battery was around 70%.
When I tried to turn it on again, power led blinks 5times and nothing happened in the display. Although I can see that pixels were turning on in the display. I removed battery and press power button for 20 seconds then turn it on using adapter but same thing. I reseated RAM and unplugged touchpad and all other unnecessary usb cables from motherboard and tried to turn it on, but power led blinks for 3 or 5 times then goes solid for 30 seconds and then shutdown. I can see that pixels of display turns on but nothing happening on the display, it is all black, not the acer logo. Now when I am trying to turn it on, power led goes solid without blinking, fan and HDD rotates, pixels turn on in the display and everything shuts down after exact 30 seconds.
Any help will be appreciated.
 

asheeshkumar636

Prominent
Feb 2, 2018
4
0
510
0
Quick update!
I put all the parts in sunlight for one day, assemble again and try to power on the laptop, power led blinks for three times then goes solid for 30 seconds then turn off. Without RAM it was blinking one time then solid but not shutting down so I think there may be problem with RAM, I put it in another slot then something different happened. While RAM in first slot, power led was blinking (means quick turn off), while RAM in second slot, power led was not blinking, it was trying to start the laptop but then after a second it was turning off cause I could hear the sound of HDD turning off. It happened five times then suddenly display came on.
Laptop started and worked fine. I put RAM in first sot again and power on the laptop and surprisingly it turned on.
Now it is working fine but I don't know how long it will last.
Can someone tell me why it is happening?
Thanks
 
Thread starter Similar threads Forum Replies Date
r090t9 Laptop Tech Support 5
HolyDog Laptop Tech Support 5
P Laptop Tech Support 1
N Laptop Tech Support 1
D Laptop Tech Support 6
9 Laptop Tech Support 1
A Laptop Tech Support 3
B Laptop Tech Support 1
K Laptop Tech Support 1
M Laptop Tech Support 9
G Laptop Tech Support 1
M Laptop Tech Support 2
C Laptop Tech Support 1
C Laptop Tech Support 1
feelinfroggy777 Laptop Tech Support 2
feelinfroggy777 Laptop Tech Support 3
C Laptop Tech Support 1
freiord Laptop Tech Support 1
T Laptop Tech Support 1
E Laptop Tech Support 1

ASK THE COMMUNITY