Acer V5-552 won't start


Apr 11, 2016
Hello, I have an Acer V5-552 laptop, bought almost 2 years ago. It worked pretty nice until a few months, when I started noticing its cooler is a bit noisier than usual. I mean, as far as I've been using it, I've seen 2 stages, the first one, when the cooler spins slow and the second, when it starts spinning really fast. Well, for the past few months, almost every time, when I watched a youtube video, or something, it started the fast spin. I didn't gave it too many attention and I started watching the videos low quality. And now, the real problem:

-Yesterday, I don't remember what happened, but I had to restart it. After that, I got an error, something like "critical process died". It got stuck there, so, eventually, I restarted it by long-pressing the power button. I turned it on again, and this time, it didn't turn on. I got some error notification, saying they are collecting data, and it will restart afterwards. Well, after restarting, the screen wouldn't turn on. It was like the screen was flickering, betwen the color it has when it's turned off and the color it has when I turn it on, right before the Acer logo appears. And it got stuck this way, continuos flickering, at about one second period. In the meantime, the cooler was spining at full speed. After waiting about 10 minutes, I turned it off again, long-pressing the power button. It turned on, I saw the Acer screen, and everything, but it was the same error, with the same restart and the same result.
I'd also like to add that there were 2 times when I was able to enter Windows normally, without any trouble.
I tryed reinstalling it, but it would'n recongnise my USB flash drive. It was bootable, with Rufus.
Now, the problem is I am stuck with the screen flicker. No Acer logo, no Windows. When I turn it on, the cooler runs for a second. The screen flikers between the two blacks. Then it shuts down, due to the heating, I think.
I tryed pressing with a paper clip the reset battery button, with the charger dissconected, with no effect at all.
I don't know what I could possibly do. I would send it back to warranty, but I can't, because, last year, it felt, in his bag, and it has something they will surely consider enough mechanical shock to void the warranty. I will give it a try, anyway, but if you could give me an alternative, I would be really grateful.
The exact model name is Acer V5-552-10576G50aii.
CPU: AMD A10-5757M
GPU: AMD Radeon 8650G

Thank you.

Here are some troubleshooting steps that I suggested to others who had the same problem with their laptop.
- Start by doing a hard reboot, remove the battery and unplug the AC adapter then press and hold the power button for 20 seconds then try booting it up again.
- If this will not work, do test the AC adapter if it's working properly. Remove the battery and power the laptop with just the AC adapter connected and see if it will boot up or not. do also try a different AC adapter that has the same voltage and see if it will work or not.
- Proceed with reseating the RAM's if trying a different AC adapter will not work, remove them all for couple of seconds then put them back in making sure everything is seated properly.
- If it will still not work, connect an external monitor and see if you'll get any display from it. If there's a display on the external monitor that could mean that the problem is the built in display.
- But if there's still no display on the external monitor that means the problem lies in the motherboard. Do contact ACER support for a repair since its still under the factory warranty.