Adobe Premiere Pro not Utilizing GTX 980Ti

Afrokk

Commendable
Mar 21, 2016
1
0
1,510
0
Hello guys,

I recently bought a Gigabyte Xtreme Gaming GTX 980 Ti to boost my rendering times in Adobe Premiere pro CC. I usually render 4K videos captured by a Panasonic camcorder. So, after getting the 980 Ti, I rendered a video, but my rendering times were same as before (12 minutes on 4 minute 4K footage). So I opened GPU-Z while rendering and my GPU was at 0% load and the temps were also at 40s (idle). The CPU (i7 4770k) was at 100% load.

I have enabled Mercury Playback Engine (CUDA) in Adobe Premiere but still it uses only CPU. Anything I can do to make Adobe use my $800 GPU? :\

Full Specs:
Intel Core i7-4770k CPU
Gigabyte Xtreme Gaming GTX 980 Ti 6GB
16GB Corsair Vengeance RAM
ASUS H81M-K
Cooler Master Elite 350 Chassis
240GB Patriot SSD + 2TB WD Black HDD

Is it because my motherboard is low-end? Is there anything I can do to fix this? Help will be appreciated.
Thanks.
 
Thread starter Similar threads Forum Replies Date
B Apps General Discussion 1
G Apps General Discussion 1
S Apps General Discussion 1
F Apps General Discussion 5
S Apps General Discussion 3
Z Apps General Discussion 10
C Apps General Discussion 1
J Apps General Discussion 1
AR_4 Apps General Discussion 1
noyaus Apps General Discussion 5
T Apps General Discussion 5
A Apps General Discussion 2
D Apps General Discussion 3
A Apps General Discussion 2
AGiLE KiTTY Apps General Discussion 11
A Apps General Discussion 1
A Apps General Discussion 2
onlythefreshness Apps General Discussion 1
CyberBlade Apps General Discussion 3
S Apps General Discussion 2

ASK THE COMMUNITY